XForms not rendering in a solution upgraded to 11

Vote:
 

Hi,

We are experiencing that our XForms aren't being rendered, but only showing up as "EPiServer.XForms.XForm" when we try to render it in the view with the following line:

@Html.PropertyFor(x => x.CurrentPage.Form, new { XFormParameters = new EPiServer.XForms.Util.XFormParameters { PostAction = "FormPosted", SuccessAction = "FormSuccess", FailedAction = "FormFailed" } })

Our solution was originally version 7.somethin and was recently upgraded to 11.5.4. During the upgrade we added the new separate packages for XForms.

Does anyone have any pointers?

#195969
Aug 14, 2018 14:06
Vote:
 

There looks like XForms isn't loading at all. In edit mode the XForms properties are shown as a textarea with a GUID value in it.

#195988
Aug 15, 2018 8:30
Vote:
 

From v11 onwards xforms was turned into an optional package: https://nuget.episerver.com/package/?id=EPiServer.XForms can you try installing it and see if it solves your problem?

Post talking about the xforms package: https://world.episerver.com/blogs/Johan-Bjornfot/Dates1/2017/11/cms-11-and--net-standard-compliance/

#196013
Aug 16, 2018 0:35
Vote:
 

Hi David. Thank you for answering. I had added the XForms package. There turned out to be a <remove assembly="EPiServer.XForms" /> in episerver.framework.config that has been in the solution forever (and I don't know why it was there in the first hand). But that of course caused problems for me. Why you would do remove of assemblies like that I find a bit weird.

#196389
Aug 29, 2018 9:20
Vote:
 

Hi I’m glad you got this sorted in the end. One common reasons why people used to exclude assemblies as you described was to try and improve start up times as I wrote about here:

https://www.david-tec.com/2011/11/Optimising-EPiServer-start-up-times-during-build-with-EPiOptimiser/

Good luck and hope you can transition to using Episerver Forms instead of xforms soon!

#196392
Aug 29, 2018 11:01
Vote:
 

Thanks for the link and the follow up. I hope we will be able to upgrade as well :)

#196393
Aug 29, 2018 11:02
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.