Administer cannot access Community Administration page

Vote:
 

Hi All,

 

We have deployed a web site which is built with EpiServer CMS 6 and Relate Plus 2. This site works, however we cannot access the Community Administration and Moderation pages.

We can see the "Community" tab in CMS, and "Moderation Mode" underneath. If we click on "Moderation Mode", nothing will come up in the tree menu. If we try to access a page which belongs to "Moderation mode" or "Administration mode" we get "Access Denier" error.

We log-in with Administor account which comes through SQL Membership Provider and is a member of Adminisrators, WebAdmins, WebEditors, CommunityAdmins and CommunityModerators.

The web.config file we user is here: 

http://www.filefactory.com/file/fzh896wpmox/n/web_config

We have given our client a backup of the database we have in our staging environment and everything works on our staging server.

 

Thanks 

 

#59899
Jul 04, 2012 7:56
Vote:
 

Technically user needs to have TotalAdministrativeAccessRights.Moderate or TotalAdministrativeAccessRights.EPiServerCommon rights to access Moderation mode. TotalAdministrativeAccessRights.EPiServerCommon is required to access Admin mode. You can make simple test page to check user access rights. Something like that:

IUser currentUser = Common.Settings.DefaultSecurity.CurrentUser;

var canModerate = currentUser.TotalAdministrativeAccessRights.Moderate;

var canAdminister = currentUser.TotalAdministrativeAccessRights.EPiServerCommon;

What exactly happens when you go to http://yoursite/EPiServerCommunity/Moderate.aspx? Do you see standard IIS Access denied error page? Or you are redirected to http://yoursite/EPiServerCommunity/AccessDenied.aspx page? 

What happens when you try to access http://yoursite/EPiServerCommunity/Admin.aspx?

Please check your configuration for role and membership providers, it depends on your environment.

In MultiplexingRoleProvider you combine SqlServerRoleProvider and EPiServerCommonRoleProvider. But MultiplexingMembershipProvider combines SqlServerMembershipProvider and custom VetsAustraliaMembershipProvider. Does it look strange that VetsAustraliaMembershipProvider is used instead of EPiServerCommonMembershipProvider for membership?

#59928
Jul 05, 2012 12:03
Vote:
 

Hi,

I too not able to access the moderation and admin page but I get resource cannot be found error.

#71002
May 07, 2013 9:58
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.