Export error

Vote:
 

I tried to export my live site to import on my developing server to get the site correct but got a lot of error messages of two kinds:

Can't resolve non-rooted path

or some similar to this

/link/63c92d48686b4af49013c40f4edcf9a9.aspx?epslanguage=sv' is not a valid virtual path.

What seems to be the problem and how can I correct this? I really don't get anymore information of where the problems occur, on wich pages or so.

#19301
May 02, 2008 15:11
Vote:
 

Hi Tobias,

I hade the same error as you had. It is beacuse its a bug in EPiServer. If the user has created a link in HTML editor to an EPiServer page and linked it to a specific language it will produce an error when importing.

A workaround is set the link to be automatic to be able to do an import. See the link tool, you can set the link to be automatic.

I have reported the bug to EPiServer and it has error number, #9639 Exporting pages with links to specific languages produces a warning of an invalid path.

Best Regards
Anders

#19302
Apr 02, 2008 15:02
Vote:
 
Any update on this matter? How do i find the status of this error #9639?
#19653
Apr 23, 2008 11:21
Vote:
 

Hi

You should be able to track the bug at our bug list. You can find it here:

http://www.episerverworld.com/Support/Bug-List/

 

#19654
Apr 23, 2008 11:39
Vote:
 

Dont know if that section is for Partners only because my "regular" login doesn't work. But is there a workaround for this or a way to get the info wich links cause this error because i get abut a 100 of these error messages and the error messages aren't that descriptive ;). 46 of the type

'/link/e5ec405738834c7c84d75b7157811a5b.aspx?epslanguage=sv' is not a valid virtual path.

and 47 of the type

Can't resolve non-rooted path

and it would be great to fix this since we are about to change the server and need to export the pages to the new one.

#19657
Edited, Apr 23, 2008 11:56
Vote:
 

Hi

Not sure about the access to that section, it may be partner only. You'd have to ask the people who run this site.

As for the bug, 9639, it is still in the state open, ie it has not been fixed.

As for the bug, when I read it it say that the message is only a warning, not an error. So that the export works, only it gives some warnings. I think that is the reason it is "only" prioritized as a normal bug. But we may have misunderstood the effects of the bug, that it's more severe than we thought. If so, we should increase the priority to high, which would cause the bug to be fixed sooner.

So I was wondering, what happens to the links when you import the export file that had the warnings? Are the links corrupted, or do they still work?

#19658
Apr 23, 2008 13:18
Vote:
 

Hi,

Yep, the buglist is currently only for EPiServer Partners.

Regards Per

#19659
Apr 23, 2008 14:22
Vote:
 

it might be me that made the wrong assumption regarding the export. When I try to export only pages from the startpage the export starts to count the pages up to 2397.

When it then starts to count up the files it stops at 32 or 33 and after a while a popup window appears saying something like "the connection to the server has been dsiconnected. please try again" or in swedish wich I have "kopplingen till servern har blivit avbruten. Vänligen försök igen".

After that I tried the same operation but with error log and then got all this errormessages I assumed that it had something to do with why the export fails. But that might not be the case, perhaps?

So can anyone tell me how to get the export to work or how I can get all the EPiServer pages to the new server?

#19665
Edited, Apr 24, 2008 8:32
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.