No registered virtual path providers are accessible

Vote:
 
Or in swedish "Inga registrerade tillhandahållare är åtkomliga för filsystemet " Did anyone get this problem after deplying website from VS2005 to IIS on seperate or localhost server? Appearantly googling did not helped. Found just one post that says its a precompilation issue. I have prevented precomilation by checking "Allow precompiled sites to be updated". Just stuck. :-( This i get in FileManagement (Filhantering) from Admin menu. As a result I cannot upload anything(no image) from the edit menu.
#16002
Mar 25, 2008 19:07
Vote:
 
And yes. Wildcard is enabled. So thats not the problem
#16785
Mar 25, 2008 19:18
Vote:
 
Hi Vijay! Exactly where do you have the "Allow precompiled sites to be updated"? Vistual Path Proveders does not work with pre-compiled sites and EPiServer CMS is relying on them to handle files. So you can not touch your site aspnet_compile in any way or use the Visual Studio Web Deployment Project. The reason? ASP.NET ignores registration of VPP if site is precompiled! Code inside ASP.NET: public static void RegisterVirtualPathProvider(VirtualPathProvider virtualPathProvider) { if (_theHostingEnvironment == null) { throw new InvalidOperationException(); } if (!BuildManager.IsPrecompiledApp) { RegisterVirtualPathProviderInternal(virtualPathProvider); } } There is a workaround if you want to precompile the site: http://sunali.com/2008/01/09/virtualpathprovider-in-precompiled-web-sites/ Kind regards, Fredrik Haglund, INEXOR AB - http://blog.fredrikhaglund.se
#16786
Mar 25, 2008 19:18
Vote:
 

Here's another EPiServer-specific workaround for virtual path providers in precompiled websites (it's based on the workaround Fredrik mentions):

http://labs.episerver.com/en/Blogs/Ted-Nyberg/Dates/112276/9/How-to-make-virtual-path-providers-work-with-precompiled-EPiServer-websites/

#23467
Sep 06, 2008 19:51
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.