Startpage wont work without language preference

Vote:
 
We have a CMS 5.1.442.4 with hostheader "site.domain.se" The only way we can get the startpage to display is to type either: http://site.domain.se/default.aspx OR http://site.domain.se/sv we have tryed to put this in web.config but it just wont work? We tried this both with language support enabled and disabled. Any suggestions?
#15852
Mar 25, 2008 19:07
Vote:
 
Error message is: Object reference not set to an instance of an object. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.NullReferenceException: Object reference not set to an instance of an object. Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. Stack Trace: [NullReferenceException: Object reference not set to an instance of an object.] System.Web.HttpContext.RewritePath(VirtualPath filePath, VirtualPath pathInfo, String queryString, Boolean setClientFilePath) +40 System.Web.HttpContext.RewritePath(String filePath, String pathInfo, String queryString, Boolean setClientFilePath) +51 EPiServer.Web.UrlRewriteModuleBase.BeginRequestEventHandler(Object sender, EventArgs e) +585 System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +92 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64
#16494
Mar 25, 2008 19:09
Vote:
 
I experience the same error. I have a supportcase with EPiServer Support, but have not come to any conclusion yet.
#16495
Mar 25, 2008 19:09
Vote:
 
We had the same problem. Then I applied all the latest updates/security patches for .NET framework from Windows Update, and after the updates it started working.
#16496
Mar 25, 2008 19:09
Vote:
 
If anyone are interested this fixed it: http://support.microsoft.com/kb/928365 You will get it if you update .Net framework using "Windows Update".
#16497
Mar 25, 2008 19:09
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.