Upgrading framework from 3.5 to 4.0 CMS 6R2 "The invoked member is not supported in a dynamic assembly"

Vote:
 

When following the guide (http://world.episerver.com/Articles/Items/EPiServer-CMS-60-now-supporting-ASPNET-40/) to the letter we get " System.NotSupportedException: The invoked member is not supported in a dynamic assembly."

Stack trace : 

[NotSupportedException: The invoked member is not supported in a dynamic assembly.]
   System.Reflection.Emit.InternalAssemblyBuilder.GetManifestResourceNames() +68
   EPiServer.Common.Configuration.ConfigurationSectionBase`1.GetInstanceFromEmbeddedAssemblyConfig(Assembly assembly, String configName, String sectionName, SectionPreInitDelegate preInitDelegate) +139
   EPiServer.Common.Configuration.EPiServerCommonSection.GetInstanceFromEmbeddedAssemblyConfig(Assembly assembly, String configName, SectionPreInitDelegate preInitDelegate) +40
   EPiServer.Common.Settings.LoadEntityProviders() +181
   EPiServer.Common.Settings.LoadSettings() +201
   EPiServer.Common.Web.Global.OnBeginRequest() +102
   System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +80
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +270
 
We are using :
1. CMS 6 R2
2. EpiMail 4.4 sp1
3. Composer R2
 
Since EpiMail 4.4 is a basterd to upgrade we havent bothered doing so. If we follow the stack trace its seems like this could be the issues since it refers to Episerver.Common ?
Appool and solution is set to framework 4.
 
Cheers
#55507
Dec 06, 2011 11:00
Vote:
 

Seriously! No one who have upgraded from framwork 3.5 to 4.0 with issues?

#55597
Dec 08, 2011 14:36
Vote:
 

Yes, without problem. The site didn't use Composer however, and the EPiMail version was 5 R2. And EPiServer.Common is part of the Mail stack, so perhaps 4.4 isn't compatible with .NET 4 or just needs some extra love.

#55599
Dec 08, 2011 15:34
Vote:
 

Ohh well!

This might confirm my suspicions. Although it seems like i cant uninstall 4.4 and i cant install 5.0, because of errors in the installation, so im afraid a framwork upgrade isnt duable at all just like a upgrade of mail.

Being stuck with framework 3.5 makes me wanna cry...

#55600
Dec 08, 2011 15:42
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.