Same url works on all domains

Vote:
 

We have multiple domains for each language e.g.

1. www.abc.de

2. www.abc.com

Say I have an article for dog in both english and german with urls

 

1. www.abc.com/dog

2. www.abc.de/hund

The issue that I have is that the following also works

3. www.abc.com/hund

4. www.abc.de/dog

Is it expected behavior? We are using EPiServer CMS 6.

 

 

 

 

 

 

#59838
Jul 01, 2012 20:41
Vote:
 

That's expected behavior. At least what EPiServer thinks.

#59839
Jul 01, 2012 22:26
Vote:
 

Would you consider or recommend overriding the behavior? We can possibly write custom URL provider but for every URL that gets hit, we would need to check if URL is correct for that domain. And that would mean loading the Page object before in the cycle while rewriting and also when finally URL reaches page handler.

#63359
Nov 15, 2012 20:44
Vote:
 

Hi!

I filed a bug to investigate if we can be more stricter regarding languages/sites and friendly URL:s. Might be good to know that if we do a fix, we will do this in the EPiServer 7 branch and will not be able to backport it since the friendly URL handling has been completely rewritten in EPiServer 7.

Regards
Linus Ekström
EPiServer Development Team

#63363
Nov 16, 2012 8:28
Vote:
 

I have the same question.

Linus, could you give me an update on what your query resulted in?

Additionally, is there maybe also a way to hide the "wrong" pages via Google Webmaster Tools?

#65942
Feb 15, 2013 12:10
Vote:
 

The issue has been fixed in CMS7 development branch, it should probably be available in next maintenance drop.

#65943
Feb 15, 2013 12:16
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.