Pages/Resources Redirect to login screen

Vote:
 

Hi,

I have a site that has just been deployed to a new IIS7 server.

When I try and access anypage or resource (CSS file for example),I am redirected to my logon page.

Once I logon, I can access and view all pages/files correctly!

Anyone know what may be causing this please?

#51083
May 24, 2011 11:08
Vote:
 

AccessRights:)

if the files are located in the webfolder check accessrights on the files, if they are in a vpp, check accessrights there

#51085
May 24, 2011 11:33
Vote:
 

Thanks Anders,

Do you mean check the folder permissions?
Or, would it be a setting in web.config/episerver.config?

 

#51086
May 24, 2011 11:35
Vote:
 

if you have problem getting /test.gif check test.gif inside the webfolder, guess the IIS user dont have read access

#51088
May 24, 2011 11:37
Vote:
 

the IISUser has got full permissions on all folders in the site.

I tried added "Everyone" also, but still have the same issue.

Example file is /templates/styles/basic.css

The folder and file all have permissions set.

#51090
May 24, 2011 11:42
Vote:
 

Has Anonymous Authentication been enabled on the site in IIS?

#51094
May 24, 2011 11:55
Vote:
 

Anonymous authentication is not enabled in IIS.
We have Basic Authenticaiton enabled however.

On the staging server (which this is) we require a network username/password prompt before the site is served.
This works fine on the old IIS6 box..

I've tried playing around with the Autehnicaiton settings. This has enabled me to get the site loading correctly, however, I can now not get to the logon page and CMS (I get the network prompt, but it won't accept my username/password) 

#51095
May 24, 2011 12:04
Vote:
 

Could I ask why you are using Basic Authentication? I would assume Forms authentication would do the trick (with Anonymous Access disabled). 

#51108
May 24, 2011 15:35
Vote:
 

Requirment of client to lockdown staging site with network login prompt. 

All their sites must do this.

#51109
May 24, 2011 15:37
Vote:
 

Then I think you need to add the EPiServer.Security.BasicAuthentication module to the list of http modules.

#51110
May 24, 2011 15:44
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.