Error in migrating data from EPi 5 to 6

Vote:
 

I am trying to upgrade a site from EPi 5 to 6. The upgrade itself runs fine, but the data migration fails at the same point every time.

I have tried google, but the only usable suggestion was to remove all EPiServer installations, reinstall EPi 6 and try again. Well, that didn't do the trick either.

So any ideas and help will be much appreciated. The output from the deployment center is shown below.

 

-Claus

 

------------------------

Not executing database script "C:\Program Files\EPiServer\CMS\6.0.530.0\Upgrade\Database\sql\0006_0000_0461_0000to0006_0000_0493_0000.sql" because it has already been executed.
Entering commit phase
Committed
An unhandled error has occured:
Cannot resolve dependencies for the following module(s) 
EPiServer.Cms.Shell.UI.InitializableModule
EPiServer.Cms.Shell.UI.InitializableModule
EPiServer.Web.InitializationModule
EPiServer.Web.InitializationModule
When executing
At C:\Program Files\EPiServer\CMS\6.0.530.0\Upgrade\System Scripts\Migrate Data
 (SqlServer).ps1:95 char:27
+ Set-EPiLongStringSettings  <<<< -DestinationDirectory $wizard.SelectedApplic
ation.PhysicalPath
=
Get-EPiIsBulkInstalling
Error - System.Management.Automation.CmdletInvocationException: Cannot resolve dependencies for the following module(s) 
EPiServer.Cms.Shell.UI.InitializableModule
EPiServer.Cms.Shell.UI.InitializableModule
EPiServer.Web.InitializationModule
EPiServer.Web.InitializationModule ---> System.InvalidOperationException: Cannot resolve dependencies for the following module(s) 
EPiServer.Cms.Shell.UI.InitializableModule
EPiServer.Cms.Shell.UI.InitializableModule
EPiServer.Web.InitializationModule
EPiServer.Web.InitializationModule
   at EPiServer.Framework.Initialization.InitializationEngine.CreateDependencySortedModules(IEnumerable`1 modules)
   at EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType)
   at EPiServer.Framework.Initialization.InitializationModule.StaticInitialization(HostType hostType)
   at EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType)
   at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.InitalizeEPiServer(String webConfigPath)
   at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.Initialize(String destinationPath, String virtualDirectory)
   at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.Initialize(String destinationPath, String virtualDirectory)
   at EPiServer.Install.CMS.Modules.CmdLets.SetLongStringSettings.ProcessRecord()
   at System.Management.Automation.Cmdlet.DoProcessRecord()
   at System.Management.Automation.CommandProcessor.ProcessRecord()
   --- End of inner exception stack trace ---
   at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)
   at System.Management.Automation.Parser.PipelineNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)
   at System.Management.Automation.Parser.StatementListNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)

Not executing database script "C:\Program Files\EPiServer\CMS\6.0.530.0\Upgrade\Database\sql\0006_0000_0461_0000to0006_0000_0493_0000.sql" because it has already been executed.Entering commit phase

Committed
An unhandled error has occured:Cannot resolve dependencies for the following module(s) EPiServer.Cms.Shell.UI.InitializableModuleEPiServer.Cms.Shell.UI.InitializableModuleEPiServer.Web.InitializationModuleEPiServer.Web.InitializationModuleWhen executing

At C:\Program Files\EPiServer\CMS\6.0.530.0\Upgrade\System Scripts\Migrate Data (SqlServer).ps1:95 char:27+ Set-EPiLongStringSettings  <<<< -DestinationDirectory $wizard.SelectedApplication.PhysicalPath
=Get-EPiIsBulkInstallingError - System.Management.Automation.CmdletInvocationException: Cannot resolve dependencies for the following module(s) EPiServer.Cms.Shell.UI.InitializableModuleEPiServer.Cms.Shell.UI.InitializableModuleEPiServer.Web.InitializationModuleEPiServer.Web.InitializationModule ---> System.InvalidOperationException: Cannot resolve dependencies for the following module(s) EPiServer.Cms.Shell.UI.InitializableModuleEPiServer.Cms.Shell.UI.InitializableModuleEPiServer.Web.InitializationModuleEPiServer.Web.InitializationModule   at EPiServer.Framework.Initialization.InitializationEngine.CreateDependencySortedModules(IEnumerable`1 modules)   at EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType)   at EPiServer.Framework.Initialization.InitializationModule.StaticInitialization(HostType hostType)   at EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType)   at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.InitalizeEPiServer(String webConfigPath)   at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.Initialize(String destinationPath, String virtualDirectory)   at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.Initialize(String destinationPath, String virtualDirectory)   at EPiServer.Install.CMS.Modules.CmdLets.SetLongStringSettings.ProcessRecord()   at System.Management.Automation.Cmdlet.DoProcessRecord()   at System.Management.Automation.CommandProcessor.ProcessRecord()   --- End of inner exception stack trace ---   at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)   at System.Management.Automation.Parser.PipelineNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)   at System.Management.Automation.Parser.StatementListNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)

#47319
Jan 24, 2011 11:42
Vote:
 

Do the EPiServer files exist in the GAC? What versions? Look specifically for the failing EPiServer.Shell.UI and it's dependencies EPiServer.Data and EPiServer.Shell (and System.Web.Mvc, version 1). The installer should register them, but doesn't hurt to check.

#47322
Jan 24, 2011 13:48
Vote:
 

The files exist in the GAC.

EPiServer.Shell.UI, EPiServer.Data and EPiServer Shell all in version 6.0.318.113 and

System.Web.Mvc in version 1 (I removed version 2, just in case...)

So everything should be fine in the GAC.

#47332
Jan 24, 2011 16:45
Vote:
 

Any solution to this problem Claus? I´m currently in the same situation as you were. :/

#53070
Aug 26, 2011 9:45
Vote:
 

As far as I remember we ended up making a completely blank site (no standard templates either), attached the database to it and ran the update "through" the blank site. It sounds really wierd, I know, but it has worked for me twice now.

#53072
Aug 26, 2011 9:56
Vote:
 

Okay, I did a new CMS 6 R2 installation and after a while this problem occurs. I´ve deleted dlls, re-referenced them, checked that all dll files exist, changed app pool etc. All solutions I could find but no... I post my solution if I find one :) 

Thanks.

#53073
Aug 26, 2011 9:59
Vote:
 

Just ran into this issue when trying to upgrade CMS5 R2 to CMS 6. Any solution for it yet?

#58851
May 09, 2012 9:55
Vote:
 

I ran into this problem today. I Installed a new site without database, took the contents from the bin folder of that site and copied it into <drive>:\Program Files (x86)\EPiServer\CMS\6.0.530.0\bin and ran the upgrade again.

i explained it in this blogpost: http://www.christianengvall.se/upgrading-episerver-cms-6/

#61676
Sep 27, 2012 12:40
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.