Episerver Teething problems

Vote:
 

Hi,

I have a couple of things i'm stumbling with on my inital attempt with Episerver. 

I have set the main navigation to be ordered by sorting index but it doesn't seem to be doing that.  Is there somewhere else i need to change this setting?

The main navigation on the public templates seems to be set to a specific number of menu items.  Can I increase this somewhere?

Thanks and apologies again if these are already answered questions! any support appreciated!

Gwen

#40026
Jun 09, 2010 10:13
Vote:
 

The EPiServer webcontrols most used to render menus (for example in in the public templates) have properties to force both the number of items visible (MaxCount) and the sort order. It may be that the sort order is also set in the control so that it is not affected when you chang the sort order of the "menu container" page.

I don't have the public templates installed right now, but you probably have a TopMenu.ascx which uses a MenuList to render the top menu. Look there for these settings.

#40030
Jun 09, 2010 10:59
Vote:
 

hi,

sorry i'm not finding anything in there that would specify an amount or a sorting order! any other help out there? I am also looking to find out how to stop the start page appearing in the top navigation

Thanks

Gwen

#40033
Jun 09, 2010 11:26
Vote:
 

The start page is put there by a callback method attached to the menulist control in the codebehind of TopMenu.ascx (or if it's called MainMenu.ascx?). Remove that callback and the start page will disappear.

The number of items shouldn't be limited if MaxCount is not set. Could it be that they overflow the container and are hidden?

I guess the top menu is listing the children of the start page. Have you set the sort order rule on the start page and then updated the indexes of it's children to reflect the order that you want? Have you published all the changes?

#40036
Jun 09, 2010 11:39
Vote:
 

thats brilliant thank you! the first two worked a treat.  The start page has sort order set to sort index but it doesn't seem to be applying it.  I have looked at this in the settings tab of the home page.  Is there anywhere else I can look?

Thanks for your help

#40039
Jun 09, 2010 12:06
Vote:
 

In edit mode, click edit on the startpage. Go to the advanced information tab and uncheck the box "Display page in menus".

Sorting works like this:
- set sorting on a page to "According to sort index" . This will affect all subpages, not the pages on the same level
- go to the subpages and set the "sort index" under advanced information to a rising number sequence.
- this will display the subpages sorted according to their sort index

#40040
Jun 09, 2010 12:06
Vote:
 

Hi Lars,

this "Display page in menus" was disabled. The "sort order" is also disabled but set to "according to sort index" and still not working!

Thanks

Gwen

#40041
Jun 09, 2010 12:08
Vote:
 

Disabled? Are you working on globalized templates? If so, you need to set the display in menu on the master language.

Are your pages sorted when you look at them in the page tree in edit mode?

#40042
Jun 09, 2010 12:10
Vote:
 

i am working on public templates.  Not all settings are disabled.  On page type start these two are. The pages add themselves in the wrong order when i create them in edit mode

#40043
Jun 09, 2010 12:13
Vote:
 

The Public templates can be installed with globalized content, which is probably what you have. As Lars said, some options are disabled for languages other than the master language. You need to select the master language in the page tree (language selector below the tree in CMS 5) to set these properties.

When you add pages in edit mode they are created with sort index 100 by default, so sort order by index doesn't really work unless you set the sort index for both old and new pages. Look at how the pages sort in edit mode which does follow the sort order settings of the parent. Menu controls and other listings may not (depending on settings, implementation...).

#40044
Jun 09, 2010 12:18
Vote:
 

hi, there is only one language on this site and this has been set to English (United Kingdom)

#40045
Jun 09, 2010 12:27
Vote:
 

There seem to be something wrong with your installation... Go to your episerver.config file and set the uiShowGlobalizationUserInterface setting to true. This will give you three new icons in edit mode. Make sure English is active under Available languages. When you click the "Language overview" icon, you should see a list of your pages and which language they are created in.

In admin mode, go to the Config tab and click on "Manage web site languages". Make sure English is in that list as well.

#40046
Jun 09, 2010 12:42
Vote:
 

Hi

uiShowGlobalizationUserInterface is already set to true

all of my pages are set to English (united Kingdom)

english is also in the other list

#40049
Jun 09, 2010 12:52
Vote:
 

Is English also marked as an available language (in edit mode)?

#40131
Jun 10, 2010 8:13
Vote:
 

sorry to sound a bit think but how can i see that? in the "show page tree" i can only see english uk which is correct

#40151
Jun 10, 2010 11:36
Vote:
 

You set available languages in admin mode.

#40154
Jun 10, 2010 11:55
Vote:
 

Hi Per,

yes I have done that... and I have checked that that is the only option showing up on the edit mode.  That is working correctly.  The issue I can't find a solution to is the sorting order at th emoment

#40155
Jun 10, 2010 12:02
Vote:
 

My question from yesterday:
Are your pages sorted when you look at them in the page tree in edit mode?

Followed by Magnus' comment:
When you add pages in edit mode they are created with sort index 100 by default, so sort order by index doesn't really work unless you set the sort index for both old and new pages. Look at how the pages sort in edit mode which does follow the sort order settings of the parent. Menu controls and other listings may not (depending on settings, implementation...).


Is this not working? Try this:
1)
Create a page called "Sorted subpages", go to advanced information and make sure sorting is set to sort by index.
2)
Create a subpage called "Test 2", go to advanced information and set the sort index to 200.
3)
Create a subpage (subpage of "Sorted subpages") called "Test", go to advanced information and set the sort index to 50.
4)
After you publish "Test", it should be displayed above "Test 2" in your page tree. If not, try to press the "-" symbol in front om "Sorted subpages" and press the "+" again when it collapses.

Does your solution work like this?

#40156
Jun 10, 2010 12:09
Vote:
 

Also have a look at page 23 i the editor manual. All documentation are available here:

http://world.episerver.com/Documentation/Categories/EPiServer-CMS-Version/EPiServer-CMS/

#40157
Jun 10, 2010 12:13
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.