Context menu always appears in IE



We seem to be having an issue with the context menu in CMS pages.

In IE, the context menu (with Edit/publish/cancel actions) is still available after signing out. We've tried clearing cookies and we've also tried with IE from other machines where we had not previously visited the site.

In Firefox it is only available while signed in.

This issue seems to have started recently, but we are not sure what might have caused it.

Any ideas or suggestions?




May 05, 2010 16:53

Hi again,

I've noticed that it is not happening everywhere, it seems to be appearing on our home/search page, but not on other pages. All the pages are using the same master page.

Could an IIS Rewrite in the web config cause this sort of issue?


May 07, 2010 15:20


Jun 01, 2010 20:34

it sounds initially like some kind of cache. Since its only effecting IE it sounds like its browser dependent and that also suggest some cache issues. But i am asuming that you tried removing like offline content after log off and see whats happening. Would not solve the undelaying issue..  

Does this appear on only 1 machines IE or have you tried from other machines? If it is only on 1 machine it can be some settings somewhere...

If you are using IE 8 you can use IE toolbar to look at the cookies (Cache -> cookie information) after clearing is there any information left there?


Otherwise its hard to try and figure out what might be wrong.

Jun 02, 2010 11:08

Thanks John,

I think I've tried most of what you are suggesting.

Is it possible that windows security (local admin) could come into play even though the Multiplex provider doesn't use it?

Is there a variable I could check in debug mode that might give me an idea?

Thanks again



Jun 03, 2010 14:59
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.