Support for Visual Studio 2010

Vote:
 

I just installed a new playground machine for CMS 6 and didn't read that is didn't support VS 2010. Is this coming soon?

I tried to convert the cms 6 public templates project and that didn't work very well at all.

Thank good I backed up my virtual hd but sadly just with the OS.

#38977
Apr 27, 2010 12:59
Vote:
 

I did not have any noticable problems setting up CMS 6 in VS2010 (on a playground basis). I also created a little gadget for it and such. I had some minor issues since I first tried using MVC 2 but was easily solved by going back to MVC 1 again. I don't know if I have some special setup that made it work (ex. at the moment Im not running it on the IIS only Visual studio Development Server). But I havent made huge things to it yet either. 

Im sure there are others that have tried too and might have more insight.

#38982
Apr 27, 2010 14:15
Vote:
 

VS 2010 works fine, but .NET 4 is not quite supported yet. See: http://world.episerver.com/Templates/Forum/Pages/Thread.aspx?id=38513&epslanguage=en. I'm using .NET 3.5, VS 2010 and EPiServer CMS 6 on a project right now.

#38985
Edited, Apr 27, 2010 14:37
Vote:
 

Strange. When I try to open the public templates project file and convert it, it fails miserably and only manages to convert the assemblyinfo.cs.

Crap I don't have time for this.

#39013
Apr 28, 2010 9:30
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.