EPiServer ContextMenu covered by standard local menu in Firefox

Vote:
 

Hi,

I am considering upgrading our 5r2 site to 6. Nice to have the rich editor also with Firefox, and i just love the new editor's search functionality.

- not to mention the drag'n drop ordering of properties ;-)

But - there is one problem with the context menu in Firefox (3.6.10 I use): When you right-click, the EPiServer menu is shown, but at the same time it's covered with the default Firefox local menu.

Any way to fix this, anyone ?

#45951
Nov 23, 2010 14:20
Vote:
 

I'm using Firefox 3.6.12 without any problems (never heard of anyone else having this problem). I would try closing Firefox and opening the page again, also make sure that you don't have any 404 errors (might need to do iisreset).

#45955
Nov 23, 2010 15:00
Vote:
 

A longshot: Also clear the browser cache / ctrl-F5 the page. Your browser could have cached the CMS 5 scripts as some of the script locations are the same in CMS 6. If then you are running the site on the same domain (like localhost if you are just trying CMS 6) you could get cached versions that don't match. I had this problem a couple of times when upgrading between CMS 5 versions.

#45959
Nov 23, 2010 15:33
Vote:
 

Well, now, it seems this problem hasn't got to do with EPiServer:

There is a setting in Firefox:

  Options | Content | Advanced Javascript settings | "Allow scripts to Disable or replace context menus"

...everything works when this is checked...

;-)

#45961
Nov 23, 2010 15:39
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.