Unified file System

Vote:
 

Hi,

I had gone through the document in http://world.episerver.com/en/Documentation/Items/Tech-Notes/EPiServer-CMS-4/EPiServer-CMS-461/Unified-File-System/

My question is the virtual name they are referring to is the folders created in the IIS for the site ? Also will this work for Episerver CMS 5

#31575
Aug 03, 2009 13:46
Vote:
 

No, UFS virtualName is not the same thing as IIS virtual folders. Also the UFS system is partially replaced in CMS 5 and is now based on Virtual Path Providers.

#31578
Aug 03, 2009 16:17
Vote:
 

I have a image folder in a server (image server)and I want the episerver in another machine to monitor the folder. Both the machines are in the same network. Webdav in episerver will not solve this problem as you need the episerver installed in the image server.

I thought UFS may solve the problem but I was not able to access/monitor the images in the image server.

Can you please help me out? 

#31588
Aug 04, 2009 6:44
Vote:
 
By monitoring I suppose you mean monitor for changes and take some action if something outside of EPiServer does changes to the folder? I think you need direct file access for that (using FileSystemWatcher etc.). You should be able to do this on a UNC however. If you don't want to give the webserver account access to the other machine you might also need to use impersonation.
#31589
Aug 04, 2009 6:52
Vote:
 

By Monitoring I meant is through file manager in Episerver, the editors should be able to see the images uploaded in the image server.

One of our task in the our project is that someone will upload the images in the server and the episerver file manager should be able to monitor those new images uploaded.Most probably, we will get the webserver account access

 

#31590
Aug 04, 2009 7:26
Vote:
 
You should be able to do that by adding a virtual path provider in web.config (dont forget to add a location as well), use the VirtualPathNativeProvider, not the versioning provider.
#31591
Aug 04, 2009 7:51
Vote:
 

I have tried this but i am getting an error saying "not able to find path"

 

Here is the config i have added:

         <add showInFileManager="true" virtualName="Upload" virtualPath="/UploadPath" bypassAccessCheck="false" name="SiteUpload" type="EPiServer.Web.Hosting.VirtualPathNativeProvider,EPiServer" indexingServiceCatalog="Web" physicalPath="\\flex-pc009\EPiServer"/>

 

Here I have given the physical path as another machine in my network.

What is the mistake I have done? 

 

 
 
#31600
Aug 04, 2009 11:02
Vote:
 
It could be that the virtual path should be relative, "~/UploadPath". Also, did you add the location path="UploadPath" with at least the static file handler (actual syntax depends on the IIS version, compare to other locations)?
#31602
Aug 04, 2009 11:07
Vote:
 

I have added the location path with the syntax based the IIS 7 version.

 <location path="UploadPath">

    <system.webServer>

      <handlers>

        <add name="webresources" path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader"/>

        <add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer"/>

      </handlers>

    </system.webServer>

    <staticFile expirationTime="-1.0:0:0"/>

  </location>

 

It still gives me the same error.

Should the virtual path should be available in the IIS or in the root folder where I have installed  episerver? Maybe I am doing something wrong here?

#31603
Aug 04, 2009 11:16
Vote:
 

The virtual path shouldn't be available neither in the local filesystem nor in IIS. It is invisible until requested from the web server (or displayed in the EPiServer filemanager).

I can't see anything wrong with the configuration. At what stage do you get the error? Can you access the network path in windows explorer from the machine running IIS? Also, check the access rights of the shared folder.

#31604
Aug 04, 2009 11:23
Vote:
 

I am able to acces the shared folder from the windows explorer and the shared folder has access to everyone.

The following  error  "Could not able to find part of path: \\flex-pc009\EPiServer" I get when I open the episerver site.

#31605
Aug 04, 2009 11:39
Vote:
 
Sorry, maybe then it doesn't work. I currently can't try with a share on a separate machine, it works fine with a share on my local machine, but maybe the framework resolves this to the local path.
#31612
Aug 04, 2009 11:54
Vote:
 

Thanks for the help. 

Is there any other possible way you could think of? I have tried everthing. If not, its fine.

#31641
Aug 05, 2009 9:14
Vote:
 
To access the files you can probably create a virtual directory in IIS. However, I don't know if you can then map this virtual directory to a virtual path provider to display it in the file manager and/or allow editors to upload files to it.
#31643
Aug 05, 2009 9:36
Vote:
 

I have added a virtual directory to the site and I have added the following line in the web.config

 <add showInFileManager="true" virtualName="ImageServer" virtualPath="~/ImageServer/" bypassAccessCheck="false" name="SiteServer" type="EPiServer.Web.Hosting.VirtualPathNativeProvider,EPiServer" physicalPath="%EpiserverUploadPath%"/>

where  EpiserverUploadPath is an Environmental Variable. EpiserverUploadPath contains the virtual directory whose path is the other machine's image folder.

However wen i try to run the site,  it says  

Access to the path '%EpiserverUploadPath%' is denied.

I have given the credentials in  the virtual directory.

#31666
Aug 06, 2009 8:22
Vote:
 

The way I interpret that is that the subsystem does not resolve the environment variable. But even if you give it an absolute path I'm not sure the VPP with accept a virual folder as physical path.

#31667
Aug 06, 2009 8:34
Vote:
 

Did anyone find a fix for this in the end? 

I am coming across this problem now.  I have the same error when connecting to a physical path on a different web server.

#35615
Dec 17, 2009 17:15
Vote:
 

Some more information:

I can access the network path in windows explorer from the machine running IIS?

I have set the access rights to everyone just for testing and I still get the access denied error

#35618
Edited, Dec 17, 2009 17:49
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.