EPiServer top right shortcut not showing up

Ted
Ted
Vote:
 

I'm a bit confused. On some EPiServer 7 sites the EPiServer shortcuts element is displayed in the top right corner when logged in, but on others it's not there.

All sites are running 7.1.

Shouldn't it always appear when logged in? What am I missing?

#69982
Apr 10, 2013 14:18
Vote:
 

For mvc, add this somewhere in your <body> (we have it at the bottom):

@Html.RenderEPiServerQuickNavigator()

I guess there is some sort of web control equivalent for webforms, though I do not know what it is called.

#69992
Apr 10, 2013 16:20
Vote:
 

IF you are using MVC

I can confirm, adding @Html.RenderEPiServerQuickNavigator() to your _Layout.cshtml (for master page implementation) and any other views that do not inherit that master layout, works and adds the episerver shortcut when logged in and viewing a page.

#70006
Apr 10, 2013 22:32
Vote:
 

Hi

When using web forms the shortcuts are added by a page extension that's called QuickNavigator. That page extension is enabled on the TemplatePage class, so if you inherit from that you will get the shortcuts automatically. If you have your templates inheriting from a different base class, then you will need to enable the extension explicitly.

Regards

Per Gunsarfs

EPiServer Development Team

#70022
Apr 11, 2013 8:59
Ted
Vote:
 

Thanks everyone who replied and clarifying why it pops up "automatically" for WebForms but not for MVC views! :) Not sure why I missed the RenderEPiServerQuickNavigator HTML helper...

#70551
Edited, Apr 23, 2013 10:37
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.