TinyMCE error

Calle Bjernekull
Member since: 2003
 

I've installed the "EPiServer Edit UI 2.0.39" addon which has som nice features regarding the languagemanager. (http://world.episerver.com/Articles/Items/Preview-of-the-New-EPiServer-7-CMS-User-Interface/)

But once it's installed the TinyMCE won't work anymore, just a blank textarea. What I can see in FireBug is that I get an 404 on this request:
/util/Editor/tinymce/plugins//editor_plugin.js?moduleArea=Util (notice the double-slash)

I placed an empty editor_plugin.js-file directly in the plugins-folder, and the editor works again. But it doesn't feel lika a good workaround. Anyone know how to fix this, and what have I done wrong?

 

#65610 Feb 02, 2013 11:48
  • Linus Ekström
    Member since: 2002
     

    Just a question: Do you think the requested URL referring to one of your own Tiny MCE-plugins or does it seem to be requesting something built in in EPiServer? Seems like it's missing the plug-in name in the path where the double slash is. We have special handling for third party add-ons since the upgraded Tiny MCE version now is located inside the CMS add-on and therefore we need to handle third party add-ons inside the util folder. But there might of course be a bug here.

    #65615 Feb 03, 2013 19:40
  • Calle Bjernekull
    Member since: 2003
     

    I don't have any TinyMCE plugins at all. So I think it's trying to request something in EPiServer, but suddenly missing the plugin-name for some reason.

    #65619 Feb 04, 2013 7:49
  • Duong Nguyen
    Member since: 2010
     

    Looks like you have a TinyMCEPlugin class without PlugInName set. Could you please dump and post your tinymce settings?

    #65621 Feb 04, 2013 9:11
  • Calle Bjernekull
    Member since: 2003
     

    Exactly what settings are you intresting in? Here are the settings in EPiServer anyway:

    https://docs.google.com/file/d/0B1GzO91ZdUbzcWJCamlIR1Nja0k/edit?usp=sharing

    #65622 Feb 04, 2013 9:28
  • Duong Nguyen
    Member since: 2010
     

    I saw an enabled plugin that doesn't have translated name, very likely a tinymce plugin from your site. Could you please search for all TinyMCEPlugin or TinyMCENonVisualPlugin in your code base?

    #65623 Feb 04, 2013 9:44
  • Calle Bjernekull
    Member since: 2003
     

    You are right! I DID have a plugin that I forgot. I'm using a code foundation for all EPiServer sites which includes a small plugin just to enable iframes. So, all I needed was to set a pluginname and add that folder to the plugin-folder.

    #65627 Feb 04, 2013 11:05
  • Duong Nguyen
    Member since: 2010
     

    Yes, as far as I know, tinymce is not fault tollerent on loading plugins on FF and Chrome. IE surprisingly works.

    #65630 Feb 04, 2013 11:14
  • Calle Bjernekull
    Member since: 2003
     

    Just found another folder missing; "/util/Editor/tinymce/plugins/epicontentfragment/editor_plugin.js", and that's a plugin that I'm sure I haven't created myself. This i requested only when editing dynamic properties and gives me a 404. I solved it the same way, created the folder and put an empty editor_plugin.js-file in it.

    #65644 Feb 04, 2013 16:52
  • eric.herlitz
    Member since: 2004
     

    I got this error as well. How did you resolve it?

    #72326 Jun 13, 2013 10:29
  • Chris Sharp
    Member since: 2011
     

    There are a couple ways you can resolve it. You could:

    1) Create an empty editor_plugin.js file in the location that is being requested to prevent the 404

    2) Create an empty file handler and set up configuration so the handler only targets the requested path. Check near the end of: http://cjsharp.com/blog/2013/04/15/how-to-add-valid-elements-like-iframes-to-tinymce-in-episerver-7/

    3) As Joshua Folkerts commented in the above link: "You can also add a virtual path to the episerver.config file to handle the new url and map it another location without using a handler. This way, you add the vp and reference the same empty js file for all plugins."

    #72372 Jun 14, 2013 12:21