CMO + Live monitor create the same tracking code break layout

Vote:
 

I've installed both CMO and Live Monitor to customer test environment and have the following issue:

One of the modules add the following tracking code to <head>: 

<script type="text/javascript">

void(function(){var tUrl = "/TrackerHandler.ashx?pageId=8&languageId=fi";tUrl += (tUrl.indexOf("?") > 0 ? "&" : "?") + "r=" + Math.random(); tUrl += "&referrer=" + escape(document.referrer);document.write("<img src='" + tUrl + "' alt='' width='1' height='1'/>");  }());
</script>

So it is basically writing an image tag to head which is bad and there is no display:none which is breaking our layout. noscript tag is added to the end of the document like this:

<noscript>
	<img src="/TrackerHandler.ashx?pageId=8&languageId=fi" alt="" style="display:none" />
</noscript>

Which does have display:none. Is this a bug in CMO? Someone else having the same issue?

 

 

#78762
Dec 03, 2013 10:52
Vote:
 

Ok, typo in title but hope you get the idea :-)

#78763
Dec 03, 2013 10:53
Vote:
 

Ok,

this time I was too hasty and did not do my homework first. There is already a thread about this in forum with possible solution:

http://world.episerver.com/Modules/Forum/Pages/thread.aspx?id=69131

 

Although it seems the place of script has changed as in my case it is set in head, not in body.

#78766
Dec 03, 2013 11:02
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.