Default language on site

Calle Bjernekull
Member since: 2003
 

I'm developing a site with multilanguage (sv and en). How do I decide what language should be default, for example, when i go to http://MYDOMAIN/ i would like the swedish to be default language. For some reason I always get english as default here. How do I change that?

#64304 Dec 17, 2012 14:25
  •  

    That would be the EPiServerFramework.config:

     

    <episerver.framework>

      <siteHostMapping>
        <siteHosts siteId="mySite">
          <add name="*" language="sv" />
        </siteHosts>
      </siteHostMapping>

    </episerver.framework>

     

     

    #64306 Edited, Dec 17, 2012 14:46
  • Calle Bjernekull
    Member since: 2003
     

    Thanks, that works half way. I'll get to the swedish startpage, but links in menues etc are english. When looking at PageData-objects when debugging, I can see that LanguageID and LanguageBranch are both set to "sv", which is correct, but LinkURL are all set to "&epslanguage=en", which even appear for pages that are not even published in english.

    #64308 Dec 17, 2012 15:24
  •  

    Are you upgrading a site from CMS 6 to 7 or is this a brand new site?

    How do you render the menus? Is your master languagebranch for the startpage swedish?

     

    #64311 Edited, Dec 17, 2012 15:33
  • Calle Bjernekull
    Member since: 2003
     

    This is a brand new site

    #64313 Dec 17, 2012 15:50
  • Calle Bjernekull
    Member since: 2003
     

    Regarding to tha db-table "tblContent", the master language branch is English for most pages. Is there any way I can change this?

    #64315 Dec 17, 2012 16:41
  • fredrik.haglund
    Member since: 2007
     

    There is no official, supported way to change master language through the API but there are tools that help you tweak the database for EPiServer 5-6. (https://www.coderesort.com/p/epicode/wiki/LanguageTools)

    I have not seen anyone do this for EPiServer CMS 7 yet...

    #64316 Dec 17, 2012 17:04
  • Marija Jemuovic
    Member since: 2010
     

    What is your globalization node in web.config file?

    <globalization culture="en-US" uiCulture="en" requestEncoding="utf-8" responseEncoding="utf-8" resourceProviderFactoryType="EPiServer.Framework.Localization.LocalizationServiceResourceProviderFactory, EPiServer.Framework" />

    If this changed, when you go to http://MYDOMAIN/, you get the correct branch (that's how it works for me).

    #64340 Dec 18, 2012 11:08
  • Calle Bjernekull
    Member since: 2003
     

    Tried globalization-settings too, no change at all

    #64358 Dec 18, 2012 13:54