CMS6 Google Analytics (SimpleAnalyticsPlugin)

Vote:
 

...suddenly stopped working about 1-2 weeks ago with:

ERROR [69] EPiServer.Global.Global_Error - 1.2.5 Unhandled exception in ASP.NET
System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.NullReferenceException: Object reference not set to an instance of an object.
   at EPiServer.GoogleAnalytics.WebControls.PopularPagesChart.CreateChildControls()
   at System.Web.UI.Control.EnsureChildControls()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.HandleError(Exception e)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at ASP.administration_cms_edit_editpanel_aspx.ProcessRequest(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\16760156\e1139690\App_Web_va4xhhgn.9.cs:line 0
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

#66376
Feb 27, 2013 16:37
Vote:
 

Did something change in the environment when it stopped working.

#66384
Feb 27, 2013 17:29
Vote:
 

Not that I know. (The google account password has been changed but according to the customer that was done after errors started)

#66401
Feb 28, 2013 9:20
Vote:
 

Anyone have a solution to this? I get the same error. I have no idea where to start looking.

#91237
Sep 30, 2014 16:32
Vote:
 

I think the plugin tries to access an outdated API at Google. That's the case for an old Analytics plugin we've used...

#91238
Sep 30, 2014 17:16
Vote:
 

OK Thanks! How did you solve it? Was there a solution to the old plugin or did you update to http://world.episerver.com/Download/Other-products/google-analytics-for-episerver/?Version=6+R2 ? 

#91280
Oct 01, 2014 13:57
Vote:
 

We haven't put any effort into fixing it yet. :)

#91281
Oct 01, 2014 14:05
Vote:
 

Any news on this?

#144394
Feb 12, 2016 9:08