EPiServer Manager: Failed to register ASP.NET client scripts on this site

Vote:
 
I get the following error when trying to install a EPiServer site via EPiServer Manager "Failed to register ASP.NET client scripts on this site [startIndex cannot be larger than length of string.Parameter name: startIndex]". I'm trying to install it on IIS7(vista). I have tried the workaround mentioned here http://www.episerver.com/en/EPiServer_Knowledge_Center/Developer-Forum2/EPiServer-Developer-Forums-/1556/11981/ without results. Cheers
#17786
Mar 25, 2008 19:42
Vote:
 
btw i'm using v2.0.19.4 of the manager
#18598
Mar 25, 2008 19:44
Vote:
 
http://labs.episerver.com/en/Blogs/Ruwen/Dates/112201/112202/Run-EPiServer-Manager-under-Vista/ /Steve
#18599
Mar 25, 2008 19:44
Vote:
 

I have the exact same problem and I don't see how the article Steve linked to helps. Did you solve the problem?

 /Christian

#19443
Apr 11, 2008 13:25
Vote:
 
For the record, we do not support Vista with EPiServer Manager - but we are working hard on the next generation installer coming later this year to support Windows 2008/Vista. This statement hopefully makes my next tip less embarrasing. Try to click on Back until you get to the first step in the wizard, then click Next again all the way to the end. Worked for me.
#19444
Apr 11, 2008 15:45
Vote:
 

Theres a conflict with the Manager and .Net versions > 2.0 (3.0 and 3.5), and it tries to invoke the aspnet_regiis from the wrong location.
Heres a (somewhat) ugly workaround:

1. Move the folders c:\windows\microsoft.net\frameworks\v3.0 and c:\windows\microsoft.net\frameworks\v3.5 to some other location (for example c:\temp)

2. run Manager as you normally would

3. after Manager is done, the folders can be moved back to their original location.

 /johan

#19446
Apr 11, 2008 18:06
Vote:
 

Duh!

Should have read the complete error description...
sorry about that.

/johan

 

#19447
Apr 11, 2008 18:07
Vote:
 

Hi, I got the same problem after I got a new computer and with SP1 for Vista installed. The solution for me was to first install an empty site within the IIS7 and use the Default App.pool. Then install the site from the manager into that site. Then deleting the site again, install a new site in IIS7 then pointing the Physical Path to the site installd by the manager. After that you follow the steps in Ruwwens blog:

http://labs.episerver.com/en/Blogs/Ruwen/Dates/112201/112202/Run-EPiServer-Manager-under-Vista/

to get the site runnig with Default App.pool settings.

 

This worked for me so hopefully you will get your site up and runnig as well!?

 

/Eric 

#19747
May 01, 2008 17:50
Vote:
 

"Try to click on Back until you get to the first step in the wizard, then click Next again all the way to the end. Worked for me."

This actually worked for me as well! (on win7) :p

#36982
Feb 16, 2010 9:50
Vote:
 
RE:EPiServer Manager: Failed to register ASP.NET client scripts on this site
Post by: Fredrik Bergqvist on: 16 February 2010, 9:50:25

"Try to click on Back until you get to the first step in the wizard, then click Next again all the way to the end. Worked for me."

This actually worked for me as well! (on win7) :p

----------------------------------------------------------------

 

Worked for me aswell, funny!

#37376
Mar 04, 2010 11:17
Vote:
 

Clicking back all the way to start of installation and start again worked for me too! Kinda strange but least it worked. :-)

#38935
Apr 24, 2010 13:38
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.