Problem with default document and System.Web.HttpContext.RewritePath

Vote:
 
Hi, I have a server with two installations of EPiServer - 4.51 and 5.1. Every thing works fine with one exception. When trying to get the defult document (startpage) for the 5.1 intstallation i get a "NullReferenceException" www.mysite.net/sv <- works www.mysite.net en><- works www.mysite.net default.aspx><- works www.mysite.net><- does not work and - yes - i've checked default document settings in iis. this is the error i get: stack trace: [nullreferenceexception: object reference not set to an instance of an object.] system.web.httpcontext.rewritepath(virtualpath filepath, virtualpath pathinfo, string querystring, boolean setclientfilepath) +40 system.web.httpcontext.rewritepath(string filepath, string pathinfo, string querystring, boolean setclientfilepath) +51 episerver.web.urlrewritemodulebase.beginrequesteventhandler(object sender, eventargs e) +585 system.web.synceventexecutionstep.system.web.httpapplication.iexecutionstep.execute() +92 system.web.httpapplication.executestep(iexecutionstep step, boolean& completedsynchronously) +64 any ideas?>
#17780
Mar 25, 2008 19:42
Vote:
 
.Net Framework 2.0 SP1 solves the problem http://www.episerver.com/en/EPiServer_Knowledge_Center/FAQ_EPiServer_4/Hotfixes-and-known-issues/Getting-Object-reference-not-set-to-an-instance-of-an-object-in-site-root/
#18595
Mar 25, 2008 19:44
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.