Failed to register ASP.NET client scripts on this site

Vote:
 
Hej! Får ett fel när jag försöker installera episerver i ett virtual-directory: Failed to register ASP.NET client scripts on this site [The system cannot find the file specified] Jag kör .NET 1.1 med senaste servicepacket.. Någon som vet vad det beror på?
#17376
Mar 25, 2008 19:32
Vote:
 
Sounds like there is something missing in your .NET 1.1 framework. Try running "aspnet_regiis.exe -i" in a DOS prompt and see if it helps.
#18088
Mar 25, 2008 19:42
Vote:
 
Hjälpte det att köra aspnet_regiis? Får samma fel men aspnet_regiis tycks inte hjälpa mig.
#18089
Mar 25, 2008 19:42
Vote:
 
Could you try to run Filemon at the same time when you're installing a new site and see what it says (especially error messages are interesting)? Only include the word "aspnet_regiis" in Filemon to track the aspnet_regiis problem. You can download Filemon from http://www.sysinternals.com/Utilities/Filemon.html
#18090
Mar 25, 2008 19:42
Vote:
 
I had the same problem. After analyzing Filemon output filtered on "aspnet_regiis", I found that EPiServerManager tried to run C:\WINDOWS\Microsoft.NET\Framework\v2.0.50215\aspnet_regiis.exe with FILE NOT FOUND result. The likely source for my problem is that I earlier installed Visual Studio 2005 beta experience kit and it caused a lot of problems so I removed it and unistalled NET Framework 2.0. The folder C:\WINDOWS\Microsoft.NET\Framework\v2.0.50215 was still left on my computer and that probaly trigged EPiServerManager to run the 2.0 version of aspnet_regiis.exe. After removing the v2.0.50215 folder installation worked fine. Problem solved, thanks!
#18091
Mar 25, 2008 19:42
Vote:
 
Hi, this error message also occurs when you have installed other .NET Frameworks where aspnet_regiis.exe does not exist, for instance .NET Framework 3.0. In order to solve that just temporary move v3.0 folder from C:\WINDOWS\Microsoft.NET\Framework\ and retry installation. Regards, JK
#18092
Mar 25, 2008 19:42
Vote:
 
I had the exact same problem when trying to upgrade from 4.41 to 4.61 running ASP.NET 1.1. I temporarily moved both the v3.0 and v3.5 folders under Framework, then it worked just fine. Very annoying and I am ever so grateful that I found this post.
#18093
Mar 25, 2008 19:42
Vote:
 

Hohh..

 

I would not have found this solution if i haddent foundt this post. Thanks!

Do some one know the reasone why this is a problem?

#29111
Edited, Apr 07, 2009 9:45
Vote:
 
Thank you Jakub Krzych. That was the solution for my situation. I temporary renamed the C:\WINDOWS\Microsoft.NET\Framework\v3.0 and C:\WINDOWS\Microsoft.NET\Framework\v3.5 folders on my webserver, and the installation was succesfull!
#29401
Apr 24, 2009 13:41