EPiServer.LogService

Vote:
 
I can't get the EPiServer.Log.Analyzer.TimeSpanAnalyzer to work for web sites located in virtual directories. Any ideas? /Håkan
#17463
Mar 25, 2008 19:33
Vote:
 
Hi, I’m running the LogService in several virtual directories on my developing machines and its working. To see if the LogGenerator generates log messages do the following: Add a file appender, so all messages are stored in a file, this is easiest done by out comment the FileAppender line at bottom of EPiServerLog.config located in the root of the actual virtual directory for your web site: Change to In the file specified on the file appender (usually "c:\\EPiServerLog\\1\\Monitor\\Errorlog -file.txt" ) you should be able to se the log messages for the statistics, like this (the Page| is indicating that this is a statistics page message): 2005-10-24 13:49:48,145 |EPiServer4Release422| Page|/EPiServer4Release422/Root/Welcome to EPiServer/LogChat|2035|-1|opvxab45nefayff3aip0t1q0|http//localhost/EPiServerSample/|| If you don’t se this line the problem is located on the “client” (here the website) side, to solve this problems verify that: 1) The EpiServerLog.Config exists and is a valid XML document 2) The LogGenerator component is located on your site (usually placed at the bottom of Default.aspx) Regards, Mattias Lövström
#18256
Mar 25, 2008 19:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.