En bugg med MultiLanguage och Quick Edit i 4.31 och 4.40 RC1

Vote:
 
Hej, Jag tror att vi har upptäckt en liten bugg med Multilanguagefunktionaliteten (ML) i EPiServer. När man surfar på en site med ML och ett visst språk så verkar det som om när man väljer "Quick Edit" i högerklicksmenyn så kommer man alltid till det engelska editeringsläget oavsett vilket språk man surfar på. Jag testade även detta på 4.40 RC1 siten genom att gå till flerspråkssidan och skicka in &epslanguage=XX där XX var olika språk. Sidan visas då med olika språk men "Quick Edit" går ändå till editeringen av den engelska versionen. Det var en kund som noterade problemet så det verkar som detta ändå används "där ute" :) //Stefan Jakobsson - Adera
#17310
Mar 25, 2008 19:32
Vote:
 
Hej Stefan! Vi känner till detta problem och har valt att inte åtgärda detta hittills eftersom den medför vissa förändringar som vi inte vill lägga in i detta läge av releaseprocessen. Jag pratade dock med en annan utvecklare som också ansåg att detta borde åtgärdas så vi sade att vi skall titta på detta efter releasen av 4.40 och eventuellt göra en hotfix för detta för att få detta att fungera.
#17958
Mar 25, 2008 19:42
Vote:
 
Ok, det låter bra med en hotfix i framtiden... nu vet jag i alla fall att ni vet om problemet. Tackar! /Stefan
#17959
Mar 25, 2008 19:42
Vote:
 
OBS! Detta problem kvarstår i 4.41 0.71. Detta är ett allvarligt problem. I många falla är Snabbredigerafunktionen det bästa alternativet även i multispråkmiljöer. Det är inte säkert att det är översättare som uppdaterar sidorna. Dessutom är funktionen i nuvarande skick i princip värdelös.
#17960
Mar 25, 2008 19:42
Vote:
 
Håller med Christian, det är ett allvarligt problem. Det finns mycket övrigt att önska i ML för att göra den riktigt bra. /Håkan
#17961
Mar 25, 2008 19:42
Vote:
 
I agree on this one. The number of multi-language installations of EPiServer is increasing. For EP: If you don't have a fix on this, might it be possible to disable Quick Edit in the DOPE if the site is set up with multi language, strictly for security reasons? Frank
#17962
Mar 25, 2008 19:42
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.