EpiFind in Commerce

Vote:
 

Hi, we got a inaccurate TermCount by using TermFacet and Filter in Epi find..

We are using the multiple TermFacetFor, however in one of these TermFacets, we have a special requirement. 

For example, a variantA did not have any tags in this special TermFacet, however its related variants does have a tag, so ths variantA should be inclued in the TermFacet which meams the Terms count should show more result. However our ContentResult  ===> TermFacet ===> TermCount did not show the whole amount whereas the ContentResult ====> SearchResult =====> TotalMatching could show the accurate result after we took a special filtering. So the question is could we reset the TermCount in EpiFind.?

#248213
Feb 05, 2021 12:38
Vote:
 

To reset EpiFind you can clear index and re-index again.

#248221
Feb 05, 2021 16:16
Vote:
 

If I understand correctly, you are getting results and their TotalMatch value having difference. If so, then you need to rebuild your indexes. This will fix your issue.

If you're using shared find service you can use following setting. 

<add key="episerver:Find.ReindexMySitesOnly" value="true"/>

Then, index rebuild will not affect other environment which are using the same service url.

You can read in more detail here 

https://world.episerver.com/documentation/developer-guides/search-navigation/reindexing-a-site-without-affecting-other-developer-indexes/

Let me know if that not work.

#248251
Feb 06, 2021 10:43
Vote:
 

@Praful , thank you for your advice, I reindexed the EpiFind, however the result is the same, maybe I should do something for the field?

#248368
Feb 09, 2021 7:44
Vote:
 
#248434
Feb 10, 2021 7:47
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.