Catalog import: Some EntryRelations are not imported?

Vote:
 

We have a very large catalog (+200.000 products/variants) that is imported through the standard XML-importer in Episerver Commerce. Besides using a lot of resources, the import has been working ok for the last months, however we have now identified a few issues with some of our EntryRelation elements. 

It seems that some (~2000 out of 200.000) of our entry relations are not imported correctly (they are not imported at all), but we can't seem to find anything missing in the XML. It is consistent with regards to which variants are affected and we can reproduce it on every import. 

We have to primary questions:

  1. Is it possible to add any logging to the importer to identify entry relations that fail?
  2. Is there something wrong with our XML?:

Xml that fails:

<EntryRelation><ParentEntryCode>p2610</ParentEntryCode><ChildEntryCode>18001</ChildEntryCode><RelationType>ProductVariation</RelationType><Quantity>1.0</Quantity><SortOrder>43</SortOrder></EntryRelation>

Xml that works:

<EntryRelation><ParentEntryCode>p2610</ParentEntryCode><ChildEntryCode>18073</ChildEntryCode><RelationType>ProductVariation</RelationType><Quantity>1.0</Quantity><SortOrder>28</SortOrder></EntryRelation>

We are using CMS v. 11.18 and Commerce v. 13.25

#231416
Edited, Nov 27, 2020 9:23
Vote:
 

As I commented on the other thread, the bug is now fixed and is waiting for release (COM-12349)

#231432
Nov 27, 2020 11:02
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.