Deleted property of a variant still showing in edit mode

Vote:
 

Deleted property of a variant still showing in edit mode. I have unchecked it in metaclass of commerce manager as well.

#206044
Aug 01, 2019 11:30
Vote:
 

It sounds like the remote event was not working properly. Did you try to restart the site? 

#206045
Aug 01, 2019 11:39
Vote:
 

Yes i restarted the site but no luck.

#206046
Edited, Aug 01, 2019 11:40
Vote:
 

Do you define the property in code? if yes then that would override the metaclass definition. 

#206047
Aug 01, 2019 11:47
Vote:
 

Yes, I had defined property in variant class and later removed it but still showing in CMS UI.

#206048
Aug 01, 2019 12:04
Vote:
 

Hi Muller,

If I got your question correctly then you need to remove these properties from "Content Type"

  1. Go to Admin->Content Type
  2. Then select your page/block type
  3. Select the property that is no more in your code.
  4. And delete.

#206113
Edited, Aug 02, 2019 16:39
Muller - Aug 05, 2019 7:47
This solution is for CMS and I am looking for Commerce.
Vote:
 

Hi Ravindra,

Muller is talking about commerce variant. In commerce we have different way to remove properties. You can read more about that here
http://webhelp.episerver.com/latest/en/commerce/system-administration/catalog-meta-classes-fields.htm

#206130
Aug 03, 2019 5:40
Muller - Aug 05, 2019 7:49
The link does not explain a single way to remove. Please explain different ways.
Praful Jangid - Aug 05, 2019 8:36
Sorry Muller, This link I shared for Ravindra :)
Vote:
 

IIRC then if you remove a property from a content typent, the metafield is not automatically unlinked once you build and run the site, because it can't be determined if the property was removed, or if it has never been there. You should have to unlink the metafield yourself, but you said you did. That' strange. Did you restart the CMS site (you said you restart the site, yes, but it's unclear if it is CMS or Commerce Manager site). If you did restart the CMS site then you'd have to contact developer support for further assistance. 

#206137
Aug 05, 2019 7:55
Muller - Aug 05, 2019 15:08
i unchecked the meta field and clicked ok.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.