Wrong url in on-page editing mode

Member since: 2007

HI!

Version 7.19.2 and 8.7.1

in the new Commerce UI, i get a 404 in "on-page editing" mode in UI. the url is  

http://mygod.com:80/EPiServer/CMS/Content/en/,,5470/Products/Inspiration/Sales-Tools/Digital-print-folder-Trifold,,969__CatalogContent/?epieditmode=True

if i try to remove the comas ",," (http://mygod.com:80/EPiServer/CMS/Content/en/5470/Products/Inspiration/Sales-Tools/Digital-print-folder-Trifold,,969__CatalogContent/?epieditmode=True)

it do work. where is the problem? what does the commas mean?

I think this did work in version 7.15 and 8.2

Please help!

#118053 Feb 26, 2015 14:24
  • Member since: 2007

    try this, http://world.episerver.com/blogs/K-Khan-/Dates/2015/2/fix-for-a-catalog-ui-issue-in-episerver-commerce-8.7.1/
    if doesnot work, Is there any excetion in log files?

    Regards
    /K

    #118068 Edited, Feb 26, 2015 16:24
  • Member since: 2007

    Talking from experience, something tells me to never update to the newest version. Version CMS 7.19.2 is a headache! beeing not compatible with Commerce 8.7.1. Also when updating to the latest version you can be sure to be first with the problems to solve them yourself.... so upgrading to CMS 8 is not an option. Maybe i should downgrade to 7.19.1?

    Is Commerce 8.8 compatible with cms 7.19.2?

    #118074 Feb 26, 2015 16:57
  • Member since: 2007

    I always upgrade to Latest Commerce version as those comes with compatible testngs and gurantees dependent assemblies will work fine.
    But if we upgrade CMS first and then upgrade Commerce on top of that, There are chances that CMS is a version ahead already.

    /K

    #118075 Edited, Feb 26, 2015 17:01
  • Member since: 2007

    So what you're saying is that Commerce 8.8 is compatible with cms 7.19.2?

    #118077 Feb 26, 2015 17:22
  • Member since: 2011

    No,

    Commerce 8.8 is supposed to compatible with CMS 8.x only. CMS 8.0 had breaking changes so Commerce 8.8 was updated to work with that.

    Is CMS 7.19.2 a must have for you? 

    /Q

    #118080 Feb 26, 2015 17:56
  • Member since: 2007

    Hello Quan,

    No, 7.19.2 is not important for us. Is just that its always time consuming between the upgrades, as it was between 7.15 and 7.19. I don't want to go from one bug to another new one. Remember im in the process to upgrade from 6r2 to 7.19. Many steps.

    Now to my question: is this bug with commas ",," something i can do anything about? even one comma is working, but not two.

    #118087 Feb 27, 2015 10:17
  • Member since: 2011

    Hi,

    Honestly I'm not sure what is wrong, but the default url of catalog UI should looks like this:

    http://commercedev/EPiServer/Commerce/Catalog#context=epi.cms.contentdata:///19__CatalogContent

    So I guess your site has issues with Path and routing. Do you have any custom routing registered?

    Regards.

    /Q

    #118088 Feb 27, 2015 10:27
  • Member since: 2007

    The main url looks like that (in your example). But my problem is in the "frame" when clicking "on page editing" on one specific product in the new Catalog UI. Editing properties works. Understood?

    No custom routing.

    #118089 Edited, Feb 27, 2015 10:31
  • Member since: 2007

    Have you gone through data migration process after upgrade?
    http://mygod.com:80/EPiServer/Commerce/Migrate

    Regards
    /K

    #118090 Feb 27, 2015 10:35
  • Member since: 2011

    The data migration steps are mandatory and you must/should go through it before doing any other tasks.

    @Lucster: Can you post and screenshot with HTTP requests?

    /Q

    PS: Yes, there's trick to skip migration steps but we recommend to migrate your data :).

    #118111 Feb 27, 2015 11:04
First   1 2 3   Last 
This topic is locked because the last reply was posted more than 6 months ago. Please contact epw@episerver.com to unlock it.