Product Packages - Items Randomly Deleted

Vote:
 

Hi, 

I am running a modified version of the standard EPiServer Commerce project that ships with commerce. The challenge I’m experiencing originates from when i try to create a Product Package, found under the admin pages, once logged in, you find the “Package Editor under”:
Commerce --> Catalog Management --> Catalogs --> “any catalog you wish”  --> Create New (on the upper left side of the right window) --> New Package.

In a total random matter, all of the items in a package disappear from the “Package Items” tab. I discover this after I save the setting for the package. In an equally random matter, I find that some of the packages I create can keep the “Package Items” after I have “ok:ed” the page and saved it. This confuses me, as I have not found any reason for this behavior.

I have created multiple packages, and not found any correlation. Is there anyone that have a solution or tips for this matter?

Best Regards Tim

#47499
Jan 31, 2011 11:13
Vote:
 

Hello again,

I have had some progress in my troubleshooting.

As stated above, I have modified my project somewhat; I have added a new Display Template and a new Meta Class, to work with my current project.

The standard Display Template called Digital Camera, together with the Meta Class Digital Cameras doesn’t seem to generate any faulty packages, but when I use my own versions of those two, some packages doesn’t keep their items.

I have been troubleshooting the issue and found that SQL-Inquiries from my templates aren’t registered in the Dbo.CatalogEntryRelation database, the Digital Camera packages registers the items correctly though.

I have also tried to put data into the Dbo.CatalogEntryRelation database for the package that didn’t store its item, and that worked. The item is available after an refresh in the Commerce Manager.

Does any of you have any idea of what could be causing my troubles? I have created my templates according to the developers guide issued by EPiServer.

Best Regards Tim

#47527
Jan 31, 2011 17:08
Vote:
 

This issue has been reported to the episerver support, and will according to them be fixed in Commerce R2.

/Tim

#49919
Apr 05, 2011 15:55
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.