"The wait operation timed out"


While developing under IIS express, I get intermittent yellow screens of death with "The wait operation timed out".

This is the full response:


Rebuilding doesn't fix it. Cleaning and rebuilding doesn't fix it. Stopping IIS Express and re-running doesn't fix it. Closing the solution, reloading, and re-running doesn't fix it. What fixes it, is shutting down Visual Studio entirely and reopening.

This doesn't seem to be a commonly known issue, I haven't been able to narrow it down to specifics as to why it happens, but I think it's related to adding or removing properties on content types (doesn't happen every time I add or remove them so I can't confirm).

Visual Studio 2017

Build 15.0.0-RTW+26228.4

Latest EPi version. 

I've fiddled with empty Alloy, Alloy Demo Kit, and Quicksilver over past three months, ran into this issue with all of them. Running into the issue on a daily basis currently, so decided to make a topic.

Apr 26, 2017 12:56

To add to this:

I'm fairly certain the reason is removing or adding properties. I've been running into a 504's when I've started deploying it DXC. Thankfully this is resolved after a few refreshes, but I'm conscious of a few other topics that have mentioned timeouts. No configuration settings I have tried to increase timeout, be it in connectionstring or using the dataStore configsection, have worked.

I'm erratically able to resolve this issue occasionally by changing web.config to force a restart, but it doesn't work every time, and seems to take 4-5 re-updates to fix, other times I will give up after 5 tries and just restart visual studio.

What is going on here and how do I get Epi to not time out? 

May 03, 2017 10:22
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.