Script error when upgrading

Vote:
 

We are having severe problems in upgrading CMS to version 7

1. Entering EpiServer Deployment Center
2. All action tab -> Upgrade site with SQL Server database
3. Error occurs, as in detailed screen output below and the installation process is stalled.

Screen output (text put in bold below is coming out red on screen):

Add-PSSnapin : Cannot load Windows PowerShell snap-in EPiServer.Install.CMS.7.0

.586.1 because of the following error: Could not load file or assembly 'file://

/C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Install\Tools\EPiServerInstall.

CMS.dll' or one of its dependencies. This assembly is built by a runtime newer

than the currently loaded runtime and cannot be loaded.

At C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Upgrade\System Scripts\Upgrad

e Site (SqlServer).ps1:41 char:14

+     Add-PSSnapin <><><><  episerver.install.cms.$epiversion>

    + CategoryInfo          : InvalidArgument: (EPiServer.Install.CMS.7.0.586.1

:String) [Add-PSSnapin], PSSnapInException

    + FullyQualifiedErrorId : AddPSSnapInRead,Microsoft.PowerShell.Commands.AddPSSnapinCommand

 

An unhandled error has occured:

The term 'New-EPiCMSWizard' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included,

verify that the path is correct and try again.

When executing

 At C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Upgrade\System Scripts\Upgrade Site (SqlServer).ps1:43 char:27

+ $wizard = New-EPiCMSWizard <><><><  "upgradesitewizard" >

=Get-EPiIsBulkInstalling

 

At C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Upgrade\System Scripts\Upgrade Site (SqlServer).ps1:43 char:27

+ $wizard = New-EPiCMSWizard <><><><  "upgradesitewizard">

System.Management.Automation.ParentContainsErrorRecordException: The term 'New-EPiCMSWizard' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

Any help is appreciated

Thanks

Christian

#147709
Apr 21, 2016 17:36
Vote:
 

Do you got framework 4.0 installed?

This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

/Oskar

#147872
Apr 27, 2016 8:38
Vote:
 

I know this is more than one year old posting, but after having turned it into a support case, I gathered I should put up the actual solution onto this forum.

We decided to use one of our test environments, which was not newly set up and we had successfully installed the test sites, and use it as "work bench" for the upgrading. Then we transferred the web root and database manually to the new machine.
From that on, we applied the 7.5 Changes up to 7.5.402
This was successful and now we have started the VPP-migration tool to run over night.

#179345
Jun 08, 2017 15:27
Vote:
 

I got the same problem yesterday and got Christian to update the thread. :) In my case I had Episerver Shared Version 1.1.1259.0 installed prior to installing Episerver 7.0.586.1. Since Episerver Shared shipped with 7.0 has version 1.1.1239.0 it is not installed (because of the lower version number). Reinstalling Episerver 7.0 after uninstalling Episerver Shared solved the problem for me.

#179386
Jun 09, 2017 11:59