Delete Language

Vote:
 

How can i delete any languages from 'Config-> Webs site languages'?

#40115
Jun 09, 2010 18:15
Vote:
 

Not sure what you want to do, but if you want to remove a language, go to admin mode. Click the Config tab and go to "Manage Web Site Languages". Click on the language you want to delete, and you should get a page with Save, Delete and Cancel. By clicking Delete, you will remove the language.

#40127
Jun 10, 2010 7:57
Vote:
 

When i try to do that, it comes up with n error saying, this language is used in language settings. How can i go by deleting those pages or places this particular language been used.

#40138
Jun 10, 2010 9:35
Vote:
 

First, make sure it is not active. (There's a green check mark next to enabled languages) If you're still not able to delete it, that means you have content created in that language and you need to delete it before you are able to delete the language.

#40141
Jun 10, 2010 9:54
Vote:
 

Ok, but there is no green tick next to the language and still not letting me delete it.

#40145
Jun 10, 2010 10:10
Vote:
 

Do you get a warning message saying: "The language is used in language settings on the following pages and cannot be deleted" ? If so, you have pages created with that language which needs to be removed first.

#40146
Jun 10, 2010 10:13
Vote:
 

I do get tht warning, but i can see tht language in the edit mode bottom drop down, and it says page1. how do i find out what is page  1 in this laguage i need to delete.

Help is much appreciated.

#40147
Jun 10, 2010 10:16
Vote:
 

To see the language in edit mode, you will need to enable it in admin mode.

To go to a specific page, go to edit mode, type the page id in the search box (1 in your case) and press enter. That will take you to the page with that id.

#40148
Jun 10, 2010 10:32
Vote:
 

Deleting the language for some system pages like the start page is not possible by the way.Try switching the start page to another page first and then delete languages and switch back again.

#40703
Jun 16, 2010 10:06
Vote:
 
<p>Seems to be this is a bug in EPiServer (reproduced even in 7.1 version).</p> <p>I had the same problem as in the topic (error '<span>The language is used in language settings on the following pages and cannot be deleted: Home [4]'). But I cleared all content in the target language from the site - same error.</span></p> <p>I found that in database, there was really a row left with this language in tblContentLanguageSetting table, preventing EPiServer to delete the language. After I deleted this row manually - language was deleted successfully by EPiServer in the admin mode.</p> <p>So, the manual solution to fix the problem:</p> <ul> <li>Open <strong>SQL Server Management Studio</strong> and watch all rows of the&nbsp;<strong>tblLanguageBranch</strong> table.</li> <li>Find the one with <strong>LanguageID</strong> value equals to the language culture name you want to delete.</li> <li>Open&nbsp;<strong>tblContentLanguageSetting</strong> table and delete the row with<strong> LanguageID</strong> taken from the previous step.</li> <li>Go to EPiServer admin mode and delete the language.</li> </ul>
#71457
Edited, May 20, 2013 10:14
Vote:
 

Great! It is still actual for 7.6.2!

#115020
Jan 08, 2015 8:43
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.