EPiTrace 1.21.0.0 What to do after installation?

Vote:
 
I have downloaded the EPiTrace_1_21_0_0.zip and copied the files to the root of my CMS 5 R2 site. I have created the table and imported the PageType and created an Epitrace page. The page works and the flash-movie is playing. But nothing is shown, and the table is empty. What is the next step? What must be done in order to make epitrace log users? I can not follow the instructions in the user manual because the files that are menchened do not exist. What code do I add? What configurations have to bee made?
#32558
Sep 08, 2009 12:19
Vote:
 

Have you added the module "KeepIdForEPiTrace" in your web.config?

 system.webserver/modules

<add name="KeepIdForEPiTrace" type="EPiTrace.KeepIdForDataHandler,EPiTrace" preCondition="managedHandler" />

#32583
Sep 09, 2009 8:26
Vote:
 

I have added the module in <httpModules>, there is no system.webserver/modules and modules is not allowed under system.webserver. I cannot use preCondition, it is not allowed and causes an error.
Do I have to add something to my pages or must I configure somthing in episerverLog.config?

#32591
Sep 09, 2009 10:11
Vote:
 

System.webserver is for IIS7.

So, add
<add name="KeepIdForEPiTrace" type="EPiTrace.KeepIdForDataHandler,EPiTrace" />
in httpModules.

Also check that your uiUrl and uitUrl, under siteSettings are relative.

 

#32595
Sep 09, 2009 11:12
Vote:
 

The line is added in httpModule and uiUrl is set to "~/mysite/ui" and utilUrl is set to "~/mysite/ui". Nothing is saved to the database. Do I need to add code to any pages? How are users tracked and how does it save it to the database?

I must be missing something. In Epi4 i added <EPiTrace:Logger runat="server" ID="Logger" /> to the masterPage.

#32605
Sep 09, 2009 12:55