NullReferenceException when accessing "Automatic Emptying of Recycle Bin"

anders.murel
Member since: 2007
 

Hi!

When accessing the "Automatic Emptying of Recycle Bin" page in Admin-mode i get a NullReferenceException. When i go directly to Root in Edit-mode and click "Empty recycle bin" manually it works as it should..

Does anyone got something that can point me in the right direction?

#30159
Jun 03, 2009 12:19
mattias.lovstrom
Member since: 2003
 
Configure EPiserverLog.config and set the root logger to ALL then look in the log file what's courses the problem .
#30161
Jun 03, 2009 13:22
anders.murel
Member since: 2007
 
2009-06-03 14:03:02,072 ERROR [10] EPiServer.Global.Global_Error - 1.2.5 Unhandled exception in ASP.NET
System.Web.HttpUnhandledException: Forårsaket unntak av typen System.Web.HttpUnhandledException. ---> System.NullReferenceException: Objektreferanse er ikke satt til en objektforekomst.
ved EPiServer.UI.Admin.DatabaseJob.OnLoad(EventArgs e)
ved System.Web.UI.Control.LoadRecursive()
ved System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
--- Slutten på sporingen av intern unntaksstakk ---
ved System.Web.UI.Page.HandleError(Exception e)
ved System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
ved System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
ved System.Web.UI.Page.ProcessRequest()
ved System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
ved System.Web.UI.Page.ProcessRequest(HttpContext context)
ved ASP.cmsui_admin_databasejob_aspx.ProcessRequest(HttpContext context)
ved System.Web.HttpApplication.CallHandlerExecutionStep.System.Web..HttpApplication.IExecutionStep.Execute()
ved System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
#30166
Jun 03, 2009 14:58
mattias.lovstrom
Member since: 2003
 
 

If you hover over the link "Automatic Emptying of Recycle Bin" you should get a link like "http://localhost:50017/myUI/admin/DatabaseJob.aspx?pluginId=55"  and the identity given in the link must exist in the database table "tblPlugin" as pkId.

I hope that this gives you a hint what the issue is.

#30168
Jun 03, 2009 16:05
anders.murel
Member since: 2007
 
I upgraded from R1 SP2 to R1 SP3 and that solved the problem.
#30175
Jun 04, 2009 10:37