Need help on 'Getting started'

Vote:
 

Hi, first of all sorry if this is not the correct forum to post this question, but here goes anyways.

 Just setted up my 'evaluation' environment for EPiServer CMS 5.2.375.236 and I'm totally new to it. I completed the Getting started : Setting Up a New EPiServer Site with Visual Studio, but I think it still lacks some info for anewbie like me on the product.

I did the express install and the demo site works ok and I can edit and add content there but on this clean project I can't do the same things atleast not the same way as in the demo site.

My first question is how do I define the 'start' page in the 'Edit mode' ? I managed to get it done by first creating a new page from the top most menu 'Create new page' and the modifing the web.config by setting pageStartId=3 (the id of the page I had just created). I doubt this is the correct way to do it, so how should I do it? Also now if I right click thenode, the 'Create new' in the context menu is not enabled, but again I can create a new page from the top most menu icon 'Create new page'.

I'm just comparing to the demo site, where the right click context menu has the option available to add a page.

Next question would be, how do I create hierarchies/categories in the 'Edit view'.

I suppose most of us are starting the weekend, but I hope I could get some answers on monday.

Cheers, Antti

#33372
Oct 09, 2009 14:21
Vote:
 

Hi,

 I hope that you have found answers to your questions by now, if not then i could try giving them.

Setting it up in web.cofig is the correct way (as far as I was told during training). If you would like to give editor / admin control over this property you may have to create a custom editor / admin plug-in which would set this property in web.config. Like you can change the existing web.config through admin if you navigate to Admin | config | system settings

 You can access this property via 

     EPiServer.Configuration.Settings.Instance.PageStartId

 

I am not sure why are you not able to do right click, double check that you have got the app_browsers files in your project and you belong to the local adminstrator group. 

Creating categories is simple. Navigate to admin | Edit categories and add new cateogries.

 

 

 

#33411
Oct 12, 2009 13:56
Vote:
 

Thanks for the reply.

After I created one demo category the create new page context menu became available, weird. But that category doesn't show up in the Edit view (or how it is supposed to work?) when I create a new page I can add it to that category etc.

On top of those I had problems with the language settinsg but that I got fixed as someone else had had the same problem.

I'm running the installation with the demo licencse, but it doesn't like IP address which is from the 192.168.131.xxx range, but I know I saw a posting about that somewhere, so I need to dig it up and see if that might also cause some problems.

If any of the EPiServer folks are reading this, it would be nice if you continued a bit the getting started guide. Add the info about the pageStartId and maybe a few page dummy site creation, pretty please ;)

#33416
Oct 12, 2009 14:35
Vote:
 

Hi

It is true that the "Create new" item in right-click menu is disabled at first. However, it will be enabled after you set the available languages for your site. To do that right-click on the "Root folder" and choose "Language settings". Under the Available languages section, you need to add/select at least one language. This will enable you to create a new page now that at least one language has been enabled.

But wait, there' one more thing :) As you probably have already noticed the menu item is still disabled. You now need to refresh the left frame for the menu to update: right click on the empty grey area below "Recycle bin" menu item and choose refresh from the browser's context menu.

Hope this helps some of you, I sure was puzzled with this one too.

 

-Tommi-

 

#35240
Dec 01, 2009 11:51