Problem implementing SSL on part of site

Vote:
 
Hi, We have a customer who wishes to implement SSL on part of their site. As a proof of concept, I've amended an EPiServer 4.60 sample site (ASP.NET 2.0) as follows: 1. Create a new folder under the site root called securetemplates, and copy Page.aspx and Page.aspx.cs to this folder, changing 'Page' to 'SecurePage' do the files are SecurePage.aspx and SecurePage.aspx.cs (also amending code-behind so that the class is now 'SecurePage' rather than 'StandardPage'). The reference to '~/templates/MasterPages/MasterPage.master' in the .aspx file is retained. 2. In IIS, created a virtual directory that maps to securetemplates, and set secure communications settings to 'Require Secure Channel'. 3. Still in IIS, added a custom error handler for 403;4 pointing to the URL /redirect.htm which contains the following code: This is to redirect requests for http://xxx to https://xxx. 4. In Admin Mode, create a new page type, 'SecurePage' which is a copy of 'Ordinary web page', but has filename set to '/securetemplates/SecurePage.aspx' 5. In Edit mode, create a new SecurePage instance directly under the site root. When I save the page, I notice that the redirection is being invoked, but then get the following error: Server Error in '/securetemplates' Application Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: Could not load file or assembly 'EPiServer.Workflow' or one of its dependencies. The system cannot find the file specified. (c:\inetpub\episerver460\web.config line 134) Source Error: Line 132: Line 133: Line 134: Line 135: Line 136: Source File: c:\inetpub\episerver460\web.config Line: 134 I assume I've messed up the configuration somehow, but can't see where. Regards, Mark
#12680
Mar 25, 2008 18:35
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.