Error adding new controller

Vote:
 

Have a MVC site created using the EPi extensions for Visual Studio.  When I right click on the Controllers folder and select Add -> Controller, I get an erro stating the following:

"Could not load file or assembly 'EPiServer.Framework, Version=7.19.1.0, Culture=neutral, Public Ket Token=8fe83dea738b45b7' or one of its dependencies.  The system cannot find the file specified."

I have double checked my references and the dll is listed and exists in the location from where it is being referenced.  Copy Local is set to true, and the file exists in the bin directory of the project.

Anyone?

#116783
Feb 04, 2015 18:20
Vote:
 

I have a default AlloyMVC solution running 7.19.2 and I can't reproduce the error. Maybe trying doing a "Clean" on your solution will help fix the references.

#116851
Feb 05, 2015 20:55
Vote:
 

I tried that and had no luck.  I can go to Add and select a standard MVBC controller.  The problem only occurs when I try to add a EPiServer controller.

#116861
Feb 06, 2015 11:59
Vote:
 

Very odd since I can create epi controller just fine on my default site. Only other thing I could think of is to remove all dlls from site root bin (move to backup folder) and then in your solution do a rebuild. 

I see something similiar here: http://stackoverflow.com/questions/8524423/could-not-load-file-or-assembly-hresult-0x80131515-when-adding-controller-to-m

#116935
Feb 06, 2015 22:21
Vote:
 

I had the same problem. I noticed I had the nuget package for EPiServer.Framework version 7.19.2.0, but the error was saying it could not find version 7.19.1.0. After removing the EPiserver Nuget packages and re-installing them specifically with version 7.19.1.0, it worked again. 

#116980
Feb 09, 2015 13:42
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.