Episerver Marketing AB test module 401 error

Vote:
 

For non-admin users, the Epi Edit UI has stopped working, kicking them out with a "You have been logged out." popup.

I can't find anything in the log except this 401:

2020-08-10 15:12:39,296 [48] DEBUG EPiServer.Shell.Web.Routing.ModuleRouteCollection: Found route with values for path:~/EPiServer/EPiServer.Marketing.Testing/Stores/ABTestStore/486f3b8d-1f7a-41ce-9c9b-685d313202d3
2020-08-10 15:12:39,297 [48] DEBUG BVNetwork.NotFound.Core.CustomRedirects.CustomRedirectHandler: Begin: Get Current CustomRedirectHandler
2020-08-10 15:12:39,297 [48] DEBUG BVNetwork.NotFound.Core.CustomRedirects.CustomRedirectHandler: Returning cached handler.
2020-08-10 15:12:39,297 [48] DEBUG BVNetwork.NotFound.Core.CustomRedirects.CustomRedirectHandler: End: Get Current CustomRedirectHandler
2020-08-10 15:12:39,297 [48] DEBUG BVNetwork.NotFound.Core.RequestHandler: Not a 404 response.
Request URL: https://tpm.local/EPiServer/EPiServer.Marketing.Testing/Stores/ABTestStore/486f3b8d-1f7a-41ce-9c9b-685d313202d3?dojo.preventCache=1597036359287
Response status code: 401

It works fine for admin users.

I have reinstalled the EpiServer.Marketing.Testing package. 
Is there a right I need to assign to editors for this to work? 

#226280
Aug 10, 2020 5:41
Vote:
 

ABTestStore allows CmsAdmins and CmsEditors users. Can you check if CmsEditors is defined in episerver.framework section?

#226283
Aug 10, 2020 6:47
Arjan Paauw - Aug 10, 2020 7:23
Thanks Quan, yes that was it.. someone had refactored the Editors in another group, this hierarchical setup apparently doesn't work.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.