GetReferencesToContentItems throws exception after upgrade to latest CMS [11.30.1] and Commerce [13.26.0]

Vote:
 

Hi!

I just upgraded to CMS 11.30.1 and Commerce 13.26.0 and now I get this exception when calling ContentRepository.GetReferencesToContent(contentReference, false)

[ArgumentException: An element with the same key already exists in the dictionary.]
System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) +59
System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add) +675
System.Linq.Enumerable.ToDictionary(IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer) +334
EPiServer.DataAbstraction.ReferenceInformation.CreateReferenceInformation(DataTable data, ILanguageBranchRepository languageBranchRepository, IPermanentLinkMapper permanentLinkMapper) +3124
EPiServer.Core.Internal.DefaultContentProvider.GetReferencesToContentItems(IEnumerable`1 contentLinks) +181
EPiServer.Core.Internal.<>c__DisplayClass45_0.<GetReferencesToContent>b__0(ContentProvider p) +89
EPiServer.Core.ContentProviderMap.Iterate(Action`1 contentProviderHandler) +144
EPiServer.Core.Internal.DefaultContentRepository.GetReferencesToContent(ContentReference contentLink, IEnumerable`1 descendents, Boolean includeDescendants) +205

Any idea why?

Thanks!
/Kristoffer

#230298
Nov 03, 2020 14:05
Vote:
 

Looks like a new bug introduced in CMS Core 11.20. I will file a bug to CMS Core team (and will move this thread to CMS Forum). Thanks for bringing this into our attention

#230299
Nov 03, 2020 14:44
Vote:
 

Thanks Quan!

/Kristoffer

#230301
Nov 03, 2020 15:04
Vote:
 

Hi Quan!

I cannot find this bug in the buglist but maybe it is not supposed to be seen there?

Thanks!

/Kristoffer

#231261
Nov 23, 2020 15:40
Vote:
 

Yes, the bug needs to be "triaged" by CMS Core team, that is when they decide to fix it (and when), and if it should be public or not (in this case it should, but the description should be reviewed and cleared before making it public)

#231262
Nov 23, 2020 15:47
Vote:
 

Thanks!

#231263
Nov 23, 2020 15:47
Vote:
 

Any news about this one? We cannot upgrade untils this bug is fixed.

Thanks!

/Kristoffer

#241008
Dec 09, 2020 14:38
Vote:
 

It is in progress but that's it. I ping-ed the developer who is assigned to this bug, we'll see.

#241009
Dec 09, 2020 14:56
Vote:
 

Ok, can I find it in the bug list yet?

#241010
Dec 09, 2020 14:58
Vote:
 

Not yet, they need to make it public first. Once you can follow it CMS-17307

#241011
Dec 09, 2020 15:02
Vote:
 

The bug is now fixed and will be released in 11.20.3 :) 

#245744
Dec 18, 2020 11:51
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.