Datetime format in CMS edit mode

Vote:
 

Hi Team,

I have created "Datetime" property in one of my page type and i want to display "dd/mm/yyyy" to the editors but it is always showing in "mm/dd/yyy" format. Below are possible configuration changes i have done but still not working.

1) Updated culture attribute in web.config "en-AU"

2) Enabled only one language(i.e. en-AU) in admin => manage website language settings

3) Updated personal language to "English" under My Settings => Display Options tab

Can you please let me know if anyother configuration changes required to resolve this issue?

Thanks,

Suresh B

#201356
Feb 15, 2019 14:47
Vote:
 

Are you referring to rendering the date in All Properties view, or in the On-Page Editing view?

If it is about On-Page Editing, Preview or regular public view, by default it will render dates based on the culture set on the Thread.CurrentThread.CurrentCulture property.

Episerver will figure out the culture for you, by going through a list like this, in prioritized order (skipping to next step, if the language of a step is not enabled):

  1. The language of the current content
  2. The language of your logged-in profile
  3. The culture specified in web.config
  4. The cultures specified by the browser in the request

If your code is telling Episerver to use a specific language, it will go on top of the list.

#201460
Feb 20, 2019 8:25
Vote:
 

The language of your content and the language of the UI are two separate things. The UI language is controlled by the user settings and will default to use whatever is configured in the web.config in the uiCulture attribute on the globalization element.

See: https://world.episerver.com/documentation/developer-guides/CMS/globalization/

#202175
Edited, Mar 18, 2019 14:58
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.