Scheduled Job not running as often as it should

Vote:
 

First of all - I'm kind of new to EPiServer so I hope I haven't missed anything super obvious! :)

I have made a scheduled job that does a simple GET request to check if the site I'm working with has contact with a specific server or not, and it is working as intended. We want to get some statistical data about this for possible future development of automated error messages, and the job itself takes <1 second.

However, for some reason it only fires exactly every 70 seconds (almost every time) instead of every 10 (or 30, or 5, or 1...) seconds that I want it to. I have found a couple other subjects about this on this forum and elsewhere online but no real answer or solution.
We have almost no other scheduled jobs on the site, and looking at the tblScheduledItem in the database there are no other jobs running this often, so it shouldn't crash with anything else. Also worth noting is that the next execution time is updated properly in the database - it says that it will run the job again in 10 seconds, but it doesn't run it until 70 seconds have passed.

Does EPiServer simply not support jobs running this often? Or is there something I can do to force it to run after 10 seconds programmatically? I found a couple tutorials showing how to set up and change settings for jobs programmatically but it didn't really help.

#210903
Edited, Dec 11, 2019 14:56
Vote:
 

Eric,
Which products and versions of Episerver are you using?

#210908
Dec 10, 2019 16:30
Vote:
 

Is your get request taking time to respond? If yes then it might be the cause.

#210909
Dec 10, 2019 17:54
Vote:
 

The site must be running, in order for scheduled jobs to be executed. (link)

Is it possible that your site goes to sleep, somehow? If you manually click a link on your site, every second (to keep it awake). Will the job still run only every 70 seconds?

#210912
Edited, Dec 11, 2019 10:29
Vote:
 

Bob - We're using EPiServer CMS, v 11.11.3.

Ravindra - No, it takes almost no time at all! Less than a second. I get a response everytime so far so I guess that's not where the problem is.

Tomas - I tried clicking around the site for a while to see if it goes to sleep or anything, but it didn't help. 

I forgot to mention that I'm doing this locally on my computer at the moment, I don't know if that might have something to do with it? 
I'm gonna try and deploy this job to our preprod-server and see if it's any different there. :) 

EDIT: I tried having it on the preprod-server now but it is the same result. Only runs every 70 seconds instead of every 10 seconds.

#210922
Edited, Dec 11, 2019 13:06
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.