Error in Inline Edit after update

Vote:
 

We are getting a blank edit interface after updating to the latest version of block inline edit.

We are getting this error

epi.js:2 Uncaught TypeError: Cannot use 'in' operator to search for 'inlinereadytopublish' in
        
at _8 (epi.js:2)
at _c (epi.js:2)
at epi.js:2
at _c8 (dojo.js:15)
at _36 (dojo.js:15)
at dojo.js:15
at _37 (dojo.js:15)
at _7c (dojo.js:15)
at _f0 (dojo.js:15)
at HTMLScriptElement._10a (dojo.js:15)

We have tried to update to todays release of Cms UI but it did not help so we tried to remove the addon and then it worked.

So something is broken in:

https://nuget.episerver.com/package/?id=EPiServer.Labs.BlockEnhancements&v=0.6.0

#210873
Dec 09, 2019 11:26
Vote:
 

Henrik, could you please provide more details? What's the edit display language?

It looks like it failed to load the resources, could you please check the http code for this request:

Would it be possible for you to test this on a clean Alloy instance? I was not able to reproduce the issue unfortunately so I'd appreciate your help to reproduce.

#210884
Dec 09, 2019 20:18
Vote:
 

Thanks Bartosz, I will do that in the morning, I had to uninstall it since i needed it to work for the customer but I can add it again in a branch.

The edit interface was just grey and didn't load at all.

Get back to you in Yammer if I have any questions and here when we have a solution ;-)

#210886
Dec 09, 2019 20:59
Vote:
 

Sounds good :)

#210887
Dec 09, 2019 21:33
Vote:
 

@bartosz it works when I have the edit interface in English and not work when the edit interface is in Swedish

Will try in Alloy now

#210891
Dec 10, 2019 8:34
Vote:
 

@Bartosz it is reproducable in Alloy, just change to Swedish.

#210893
Dec 10, 2019 8:44
Vote:
 
#210894
Dec 10, 2019 8:50
Vote:
 

This is now fixed in the latest version and available here:
https://nuget.episerver.com/package/?id=EPiServer.Labs.BlockEnhancements&v=0.6.1

#210898
Dec 10, 2019 11:35
Vote:
 

Hi @Henrik/@Bartosz

could you please tell how to uninstall the Inline Edit Block?


Thanks

#215896
Edited, Jan 21, 2020 4:06
Vote:
 
#216146
Jan 27, 2020 20:19
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.