Suddenly our client can't create new pages under parts of the tree on 7.19.2.0 (option is greyed out)

Suddenly our client can't create new pages under parts of the tree on 7.19.2.0 (option is greyed out)

Member since: 2010
 

Hey, 

We have an "interesting" case on support:

All of a sudden, client can't create pages under non-start pages (those that are under root, but not under start page, no matter how nested they are).

  • Page types are mixed (availability is set correctly and they work under start, but not those under root/not-start).
  • Access rights are set correctly for languages and tree (double-checked by several people)
  • Creating a new role and new user with Create access rights doesn't solve it
  • Globalization is enabled
  • Site is under DMZ, but that hasn't changed
  • There has been no change in IP to cause licensing to break
  • There are no console errors
  • Client claims they haven't done anything. Last time they did create a page was only a few days ago. We haven't done any deploys. 

Any ideas for this mistery? :)

#181605 Edited, Aug 25, 2017 9:48
  • Member since: 2005
     

    Log4net on ALL level give any more?

    #181608 Aug 25, 2017 10:39
  • Member since: 2010
     

    It was an administration issue after all (Episerver support figure it out)

    Root page stopped having both languages enabled. Not sure how I missed to check this and client doesn't know who at their side was playing around this.

    I guess it happens :) Good that it's solved anyways :)

    #183028 Edited, Oct 03, 2017 14:35
  • Member since: 2017
     

    i have same problem with some instances of a page type where we cannot create new page (is greyed out) while on other instances we can. Can you pls elaborate how you solved this? thanks

    #187738 Feb 01, 2018 16:16
  • Member since: 2010
     

    Hi,

    If it's nothing from my first post, then you can try checking out enabled languages on parent pages.

    In this case, an editor removed some languages from Root page -> Language Settings. It's changed here.

    Hope this helps,

    Marija

    #187739 Feb 01, 2018 16:24
  • Member since: 2017
     

    My site is in swedish and i cant see 'sv' in root as you pointed out. When i try to add swedish language from tools -> language settings. it doesnt show up. pls see the screnshot here https://ibb.co/eiSYKR

    #187741 Feb 01, 2018 16:33
  • Member since: 2010
     

    Hi!

    That's strange, given that you already have pages in Swedish, perhaps Swedish is enabled on Start page? Check also on the page itself (where you are trying to create a new page). Can you check if Swedish is enabled in Admin mode? If you click on Admin -> Config -> Manage website languages?

    It doesn't look like a language issue, since you already have the entire tree in place (and pages under this page).

    Do check the access rights for that particular page.

    BR,
    Marija

    #187767 Feb 02, 2018 9:36
  • Member since: 2017
     

    I checked the mentioned areas but as you said this doesnt look like an language issue or rights issue. Thanks for help anyways

    #187773 Feb 02, 2018 9:57
  • Member since: 2017
     

    Hi, i re-checked and it was actually related to language settings for the page. The correct lanaguge was unchecked, didnt know how i missed that. 

    #187866 Feb 05, 2018 11:37
  • Member since: 2010
     

    It happens :) 

    Good you solved it!

    #187867 Feb 05, 2018 11:38
  • Member since: 2010
     

    It happens :) 

    Good you solved it!

    #187868 Feb 05, 2018 11:38