Chrome: widgets.js:2 Uncaught TypeError: Cannot read property '0' of undefined

Vote:
 

Hi, 

In all environments in Chrome only, I get the following behavior:

I start drag&dropping images to TinyMCE field and after around 5/6/7 images, I get an error in _checkAcceptance:

http://prntscr.com/c31h8b

It doesn't matter which images I add (it's not related to the particular image, since I just add three from the same folder over and over again).

This is where it breaks:

http://prntscr.com/c31ic5

Any ideas?

My Episerver packages:

  
  
  
  
  
  
  
  
  
  
  
  

Thx in advance!

#151827
Edited, Aug 08, 2016 13:39
Vote:
 

I have upgraded to latest UI packages, but still that same error (it's 100% reproducible):

  <package id="EPiServer.CMS.UI" version="9.8.3" targetFramework="net452" />
  <package id="EPiServer.CMS.UI.Core" version="9.8.3" targetFramework="net452" />

BR,
Marija

#151832
Aug 08, 2016 14:04
Vote:
 

Thanks Marija for raising those. Hopefully episerver will show the love soon. On a separate note after upgrading to the latest version we been seeing a very slow response in edit mode while switching between pages and switiching to all properties. Did you also notice any difference? I've a feeling episerver has changed something fundamentally in new version which has slow down the edit?

#151877
Aug 09, 2016 14:35
Vote:
 

Hi, 

I've reported a bug specifically for this issue since it seems its easy to reproduce.
Thanks for providing detail info. 

#151910
Aug 10, 2016 10:26
Vote:
 

Hi, Khurram,

Thx a lot, hopefully it will be easy for support to reproduce in their environments. Let me know if I can further assist with this.

@Muhammad, I am not sure I've notice a performance downgrade. It's not exceptionally fast (not too bad either), but I can't tell if it's slower than it used to be.

I can copy paste the issues from client perspective:

"Navigation and asset pane tend to freeze. Drag & drop options (e.g. pictures from asset pane into page) work only a few times, then don't react anymore. After reload they work for a while before one of them freezes up again.

I myself have encountered this at least 10 times yesterday and today while working in edit mode for several hours each day. And the same has been reported from all regions in the last days."

BR,

Marija

#151912
Aug 10, 2016 10:30
Vote:
 

I can reproduce this:

- in local IIS

- in test server IIS (standard setup, one server, VPP folder for images, etc)

- Azure (with one and multiple instances)

But, I cannot reproduce it in IIS express (I'll keep trying and get back, it doesn't look like it's a coincidence, but if I manage to reproduce it, i'll write back here).

#151914
Aug 10, 2016 10:45
Vote:
 

Hey Marija,

I've been looking into this bug and I have not been able to reproduce it. I've looked throught the code quite thoroughly and it seems to me that this scenario should not be able to occur. Also the code should fail a lot earlier if the argument "nodes" is undefined.

Are you testing on a standard Alloy template site or are you testing with a customer site? I ask this since the only scenario I can think of where this might happen is if an add-on or custom code is interfering somehow.

#152055
Aug 15, 2016 11:26
Vote:
 

It's not a standard Alloy tech, it's a customer site.

Do you think I should look into js files (if some of them are causing the conflict), perhaps try not to render any of them and then give this a try?

#152056
Aug 15, 2016 11:30
Vote:
 

Out of packages, I don't think I have anything that is likely to cause this, maybe Forms only?

<?xml version="1.0" encoding="utf-8"?>
<packages>
  <package id="AntiXSS" version="4.3.0" targetFramework="net452" />
  <package id="Antlr" version="3.4.1.9004" targetFramework="net452" />
  <package id="AutoMapper" version="3.2.1" targetFramework="net452" />
  <package id="Bower" version="1.3.5.2" targetFramework="net452" />
  <package id="Castle.Core" version="3.3.3" targetFramework="net452" />
  <package id="Castle.Windsor" version="3.3.0" targetFramework="net452" />
  <package id="Chief2moro.ImageDataExtensions" version="1.1.0.0" targetFramework="net452" />
  <package id="CommonServiceLocator" version="1.3" targetFramework="net452" />
  <package id="dotless" version="1.4.1.0" targetFramework="net452" />
  <package id="EntityFramework" version="6.1.1" targetFramework="net452" />
  <package id="EPiServer.Azure" version="9.0.1" targetFramework="net452" />
  <package id="EPiServer.CMS" version="9.10.2" targetFramework="net452" />
  <package id="EPiServer.CMS.Core" version="9.10.2" targetFramework="net452" />
  <package id="EPiServer.CMS.UI" version="9.7.1" targetFramework="net452" />
  <package id="EPiServer.CMS.UI.Core" version="9.7.1" targetFramework="net452" />
  <package id="EPiServer.Forms" version="2.1.0.2" targetFramework="net452" />
  <package id="EPiServer.Framework" version="9.10.2" targetFramework="net452" />
  <package id="EPiServer.GoogleAnalytics" version="1.9.3.9000" targetFramework="net452" />
  <package id="EPiServer.Logging.Log4Net" version="2.0.0" targetFramework="net452" />
  <package id="EPiServer.Packaging" version="3.2.4" targetFramework="net452" />
  <package id="EPiServer.Packaging.UI" version="3.2.4" targetFramework="net452" />
  <package id="EPiServer.Search" version="8.0.0" targetFramework="net452" />
  <package id="Grunt" version="0.1.13" targetFramework="net452" />
  <package id="HtmlAgilityPack" version="1.4.9" targetFramework="net452" />
  <package id="jQuery" version="1.6.4" targetFramework="net452" />
  <package id="log4net" version="2.0.3" targetFramework="net452" />
  <package id="Lucene.Net" version="3.0.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.Identity.Core" version="2.2.1" targetFramework="net452" />
  <package id="Microsoft.AspNet.Identity.EntityFramework" version="2.2.1" targetFramework="net452" />
  <package id="Microsoft.AspNet.Identity.Owin" version="2.2.1" targetFramework="net452" />
  <package id="Microsoft.AspNet.Mvc" version="5.2.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.Providers.Core" version="2.0.0" targetFramework="net452" />
  <package id="Microsoft.AspNet.Razor" version="3.2.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.Web.Optimization" version="1.1.3" targetFramework="net452" />
  <package id="Microsoft.AspNet.WebApi" version="5.1.2" targetFramework="net452" />
  <package id="Microsoft.AspNet.WebApi.Client" version="5.1.2" targetFramework="net452" />
  <package id="Microsoft.AspNet.WebApi.Core" version="5.1.2" targetFramework="net452" />
  <package id="Microsoft.AspNet.WebApi.WebHost" version="5.1.2" targetFramework="net452" />
  <package id="Microsoft.AspNet.WebPages" version="3.2.3" targetFramework="net452" />
  <package id="Microsoft.Azure.KeyVault.Core" version="1.0.0" targetFramework="net452" />
  <package id="Microsoft.Bcl" version="1.1.10" targetFramework="net452" />
  <package id="Microsoft.Bcl.Async" version="1.0.168" targetFramework="net452" />
  <package id="Microsoft.Bcl.Build" version="1.0.21" targetFramework="net452" />
  <package id="Microsoft.Data.Edm" version="5.6.4" targetFramework="net452" />
  <package id="Microsoft.Data.OData" version="5.6.4" targetFramework="net452" />
  <package id="Microsoft.Data.Services.Client" version="5.6.4" targetFramework="net452" />
  <package id="Microsoft.Net.Http" version="2.2.29" targetFramework="net452" />
  <package id="Microsoft.Owin" version="3.0.1" targetFramework="net452" />
  <package id="Microsoft.Owin.Host.SystemWeb" version="3.0.1" targetFramework="net452" />
  <package id="Microsoft.Owin.Security" version="3.0.1" targetFramework="net452" />
  <package id="Microsoft.Owin.Security.Cookies" version="3.0.1" targetFramework="net452" />
  <package id="Microsoft.Owin.Security.OAuth" version="3.0.1" targetFramework="net452" />
  <package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net452" />
  <package id="Microsoft.Web.RedisSessionStateProvider" version="2.1.0" targetFramework="net452" />
  <package id="Microsoft.WindowsAzure.ConfigurationManager" version="3.1.0" targetFramework="net452" />
  <package id="Modernizr" version="2.6.2" targetFramework="net452" />
  <package id="Newtonsoft.Json" version="6.0.8" targetFramework="net452" />
  <package id="Node.js" version="0.10.26.1" targetFramework="net452" />
  <package id="NoGit" version="0.0.5" targetFramework="net452" />
  <package id="Npm" version="1.4.4" targetFramework="net452" />
  <package id="NuGet.Core" version="2.5.0" targetFramework="net452" />
  <package id="Owin" version="1.0" targetFramework="net452" />
  <package id="PagedList" version="1.17.0.0" targetFramework="net452" />
  <package id="PagedList.Mvc" version="4.5.0.0" targetFramework="net452" />
  <package id="SharpZipLib" version="0.86.0" targetFramework="net452" />
  <package id="StackExchange.Redis.StrongName" version="1.0.488" targetFramework="net452" />
  <package id="structuremap.web-signed" version="3.1.6.186" targetFramework="net452" />
  <package id="structuremap-signed" version="3.1.6.186" targetFramework="net452" />
  <package id="System.Spatial" version="5.6.4" targetFramework="net452" />
  <package id="WebActivator" version="1.5.1" targetFramework="net452" />
  <package id="WebGrease" version="1.5.2" targetFramework="net452" />
  <package id="WindowsAzure.ServiceBus" version="3.0.7" targetFramework="net452" />
  <package id="WindowsAzure.Storage" version="6.1.0" targetFramework="net452" />
</packages>

P.S. I also have Projects enabled, but it doesn't matter if there is a selected project or not.

#152057
Edited, Aug 15, 2016 11:33
Vote:
 
<p>I also thought Forms might be the culprit but I have just done some testing with that add-on installed and have still not been able to reproduce the issue. Of course it may depend on what properties are on the page in order to determine what scripts get loaded.</p> <p>A quick fix would be to simply add an undefined check where the code fails for you, but this would not be fixing the cause of the issue since it should not be able to get into this state.</p>
#152061
Aug 15, 2016 12:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.