EPi CMS: Error when login to CMS

Vote:
 

When I navigate to CMS login page. I enter username and password then I get this error:

[ArgumentNullException: Value cannot be null.
Parameter name: username]
   System.Web.Util.SecUtility.CheckParameter(String& param, Boolean checkForNull, Boolean checkIfEmpty, Boolean checkForCommas, Int32 maxSize, String paramName) +11773375
   System.Web.Profile.ProfileManager.DeleteProfile(String username) +62
   System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +142
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +92

Anyone have any ideas?

In advance, thanks for your support.

Kind regards,

Tan

#171544
Nov 10, 2016 9:17
Vote:
 

Which membership provider are you using? Asp.Net Identity or default (v9)? Which EPiServer version?

#171646
Nov 14, 2016 15:03
Vote:
 

Hi Valdis,

I am also facing same issue and I am using WS Federation authentication.

#205899
Jul 26, 2019 15:29
Vote:
 

Which version of the CMS you are using?

#205901
Jul 26, 2019 17:31
Vote:
 

CMS 10.10.4

Commerce manager 1.0.

#205903
Jul 26, 2019 17:49
Vote:
 

Mounesh

The reason you get this error when open the CMS is because "Name" claim is missing. Check your ADFS claims transformation rule, and make sure it's mapped to one of your LDAP aatributes.

Furthermore, if you miss "Name" claim, the user won't be synced into your [dbo].[tblSynchedUser] table, therefore when Episerver Shell module tried to validate your identity, it can't find your details in that table. 

I hope this will help you to fix your problem. 

p.s. I hit on the same issue today :) 

#206190
Edited, Aug 07, 2019 6:13