ArgumentException: Value cannot be null or empty. Parameter name: controllerName

Vote:
 

Hi, the entire edit mode issues "502 – Web server received an invalid response while acting as a gateway or proxy server" and in Console I see the error below that I am posting here, in case someone came across it:

UrlReferer

https://xxx:443/yy/shell/Stores/searchproviders/?searchArea=cms%2Fpages&dojo.preventCache=1478089663843

Exception details:

ArgumentException: Value cannot be null or empty. Parameter name: controllerName

Stack trace:

[ArgumentException: Value cannot be null or empty.
Parameter name: controllerName]
   at System.Web.Mvc.HandleErrorInfo..ctor(Exception exception, String controllerName, String actionName)
   at System.Web.Mvc.HandleErrorAttribute.OnException(ExceptionContext filterContext)
   at System.Web.Mvc.ControllerActionInvoker.InvokeExceptionFilters(ControllerContext controllerContext, IList`1 filters, Exception exception)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass21.b__1e(IAsyncResult asyncResult)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeAction(IAsyncResult asyncResult)
   at EPiServer.Shell.Services.Rest.RestControllerBase.EndExecute(IAsyncResult asyncResult)
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

These are my Episerver packages:

 
  
  
  
  
  
  
  
  
  
  
  

Any help greatly appreciated.

#171196
Edited, Nov 02, 2016 13:47
Vote:
 

Now that I run this locally, I get the following error on the same URL:

The Type 'EPiServer.Shell.Search.SearchProviderSetting' needs to be remapped in the Dynamic Data Store, see the Errors collection for more information.
Remapping can be done by applying the EPiServer.Data.Dynamic.EPiServerDataStoreAttribute attribute to the type,
setting its AutomaticallyRemapStore property to true and ensuring the <episerver.dataStore><dataStore> autoRemapStores attribute in web.config is set to true (or is not defined).

No deploys for a month, so I am not sure what could have happened to cause the mismatch in DDS and code?

Found this old error: http://world.episerver.com/forum/developer-forum/-EPiServer-75-CMS/Thread-Container/2014/9/StoreInconsistencyException-EPiServerShellSearchSearchProviderSetting/?pageIndex=1#reply

#171201
Nov 02, 2016 15:22
Vote:
 

OK, eventually I found this:

http://world.episerver.com/forum/developer-forum/EPiServer-CMS-6-R2/Thread-Container/2014/5/Search-in-edit-mode-not-functional/

Now I am applying it with recommendations from Per:

http://world.episerver.com/forum/developer-forum/-EPiServer-75-CMS/Thread-Container/2015/4/search-in-episerver-edit-mode-throws-exception/

Backup the DB first :)

Let's see how it goes, but to begin with, now the query should be:

DELETE FROM tblBigTableStoreInfo
WHERE fkStoreId IN (
    SELECT pkId FROM tblBigTableStoreConfig
    WHERE StoreName = 'EPiServer.Shell.Search.SearchProviderSetting')
#171203
Nov 02, 2016 15:40
Vote:
 

So, the posts partially helped me. Delete did work, but after the restart, the application did not recreate them automatically. The cmdlet EPiRemapDDSTypes does not longer exist and I ended up with a simple tool that does the rebuild that Paul Smith created: http://world.episerver.com/forum/developer-forum/EPiServer-CMS-6-R2/Thread-Container/2012/1/Where-is-the-Upgrade-EPiRemapDDSTypes-cmdlet-/

This solved the error, but the edit mode is still so slow that it impacts the view as well and sometimes it loads and loads, but now without any logged errors. 

Then, I disabled Episerver Projects (since we have had some issues with them previously) as well as Web Sockets and now all works really fast. I'll need to troubleshoot this further, but the error with remapping is at least fixed. 

It would be really great to know why it happened out of the blue (at least it seems so).

BR,
Marija

#171207
Nov 02, 2016 17:06
Vote:
 
<p>This happened again, so I'd really like to know&nbsp;in which scenario this inconsistency occurs?</p>
#171664
Nov 14, 2016 17:15
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.