Newtonsoft.Json (>= 9.0.1)

Vote:
 

Hello,

I'm trying to use React with EPiServer, and I've found that there is a conflicting dependency on Newtonsoft.Json that prevents me from being able to install React.Core, because it depends on Newtonsoft.Json (>= 9.0.1), while EPiServer.Framework depends on Newtonsoft.Json (≥ 6.0.8 && < 9.0).

Are there any breaking changes that prevent EPiServer.Framework from allowing Newtonsoft.Json 9 and above?

#171058
Oct 31, 2016 16:59
Vote:
 

Do you have the possibility to use the older version of React and ask Episerver to in Feature requests to upgrade? This would probably take time.

#171101
Nov 01, 2016 16:12
Vote:
 

Downgrading the React version wouldn't be ideal, especially considering that waiting for an EPiServer update could take a while, and we'd be stuck on an older version of a library that moves so fast.

For now I've followed the hack suggested in this post from 2.5 years ago, and installed Newtonsoft.Json 9.0.1. Nothing has broken on the surface of things, but obviously there are no guarantees. It would be nice to know the outcome of running EPiServer's regression tests against the latest Newtonsoft.Json library, and to know which areas of EPiServer could be affected.

#171103
Nov 01, 2016 17:23
Vote:
 

This is called dependency hello u can take a look into 

http://www.continuousimprover.com/2016/05/the-magic-of-hiding-your-nuget.html

#171106
Nov 01, 2016 20:33
Vote:
 

Support for Newtonsoft.Json 9 in CMS has just gone through QA and it should be included with one of the next couple of releases. So unless you are dependent on an add-on that doesn't yet support it you should be good. Commerce and Find seems to have updated their dependency requirements already.

#171107
Nov 01, 2016 20:39
Vote:
 

That's very good to know. Thanks.

#171108
Nov 01, 2016 20:41
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.