Unable to edit global settings for rich text editor



I am currently unable to update global settings for the rich text editor on a new EPiServer 7.5 site. When I go to save the settings, I receive the message:

Invalid object name 'dbo.VW_EPiServer.Core.PropertySettings.PropertySettingsGlobals'.

This sounds like it is referring to a missing view in the database. I have checked and sure enough it is missing.

In an attempt to fix this, the latest updates and database schema changes (latest from 9th June) have been installed via nuget, but this view is still missing, and the problem still occurs.

I have checked the database that was created for the Alloy demo site by the EPiServer 7.5 deployment center, and the view is also missing from there too.

Please could somebody verify if this is a bug? If somebody has this db view, please could they provide it?

Any help is greatly appreciated,


Jun 13, 2014 11:37

It's a view created by the DDS, I think the view and it's store data objects should be created automatically.

Have you excluded some DLL's from being scanned or are you getting any errors logged on startup?

Jun 17, 2014 9:36

Thanks for the reply, I have already managed to find out the cause of this problem.

The issue was caused by running the database under Visual Studio LocalDB (SQL Server Express). If I ran the site with the database in a SQL Server 2008 instance, the issue did not occur and the views and stored proceures were created without a problem. 

Once I copied the views and stored procedures across to my LocalDB copy, it worked on there without any problem. I'm hoping that this is a one-off issue and that I don't have any other similar problems with my local DB (EPiServer have assured that SQL Server Express is supported for development environments).

Jun 17, 2014 9:54

OK! Good to know.

Jun 17, 2014 10:26
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.