Search in edit mode on localhost

Member since: 2010

Hello!

I'm performing built-in EPi search on test server in edit mode and it works well.

However, on localhost, I don't get any search results. No errors in console either. 

This is the configuration locally:

  <episerver.search active="true">
    <namedIndexingServices defaultService="serviceName">
      <services>
        <!--<add name="{serviceName}" baseUri="{indexingServiceBaseUri}" accessKey="{accessKey}"/>-->
        <add name="serviceName" baseUri="http://test-server-url/IndexingService/IndexingService.svc" accessKey="local" />
      </services>
    </namedIndexingServices>
    <searchResultFilter defaultInclude="true">
      <providers />
    </searchResultFilter>
  </episerver.search>

    

This works on 7.1 on another project. Any similar experiences? Is it me or is this a bug in 7.5? 

#81753 Feb 25, 2014 15:08
  • Member since: 2008

    Hi Marija

    The (old) documentation mentions a "allowLocal" setting that "Indicates whether the service should accept connection from all local interfaces.". Could this be your issue?

    http://world.episerver.com/Documentation/Items/Tech-Notes/EPiServer-Framework/EPiServer-Framework-61/EPiServer-Full-Text-Search-Service-Configuration/

    David

    #81757 Feb 25, 2014 17:58