Obsolete legacy APIs to improve maintainability

Fixed in

EPiServer.Commerce 13.5.0

Created

Dec 28, 2018

Updated

Jul 19, 2019

State

Closed, Acceptance tests pass


Description

The following APIs are being obsoleted:

  • Mediachase.Commerce.Catalog.Data.CatalogDataHelper
  • Mediachase.Commerce.Catalog.Data.CatalogLogAdmin
  • Mediachase.Commerce.Catalog.Data.ContentGuidAdmin
  • Mediachase.Commerce.Catalog.Managers.CatalogLogManager
  • Mediachase.Commerce.CommerceContext.CommerceContextImpl
  • Mediachase.Commerce.Core.Common.eCUD_ChangeState
  • Mediachase.Commerce.Core.Common.IValidationResult
  • Mediachase.Commerce.Engine.Template.Providers.XslTemplateProvider
  • Mediachase.Commerce.Engine.Template.TemplateProviderCollection
  • Mediachase.Commerce.Engine.Template.TemplateProviderSection
  • Mediachase.Commerce.Engine.Template.TemplateService
  • Mediachase.Commerce.Reporting.ReportingPermissions
  • Mediachase.Commerce.Security.Configuration.RoleDefinitionElement
  • Mediachase.Commerce.Security.Configuration.RoleElementCollection
  • Mediachase.Commerce.Security.CurrentUserService
  • Mediachase.Commerce.Shared.Check
  • Mediachase.Commerce.Shared.XmlSerializerSectionHandler
  • Mediachase.Commerce.Storage.DataOperation
  • Mediachase.Commerce.DefaultRequiredMetaFields
  • Mediachase.Commerce.ICommerceContext